summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-02-22 23:15:51 +0000
committerHanno Böck <hanno@gentoo.org>2009-02-22 23:15:51 +0000
commit68f4f9d131de0e8e9a84803554d9ec6406d1e108 (patch)
tree7329936e15a63b6be3ac21dfd38501b4853477c7 /www-client
parentClear out old insecure versions of vmware-workstation (bug 245941). (diff)
downloadgentoo-2-68f4f9d131de0e8e9a84803554d9ec6406d1e108.tar.gz
gentoo-2-68f4f9d131de0e8e9a84803554d9ec6406d1e108.tar.bz2
gentoo-2-68f4f9d131de0e8e9a84803554d9ec6406d1e108.zip
galeon version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/galeon/ChangeLog10
-rw-r--r--www-client/galeon/galeon-2.0.7.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/www-client/galeon/ChangeLog b/www-client/galeon/ChangeLog
index f1c450a9ff28..20c57f0175c3 100644
--- a/www-client/galeon/ChangeLog
+++ b/www-client/galeon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/galeon
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.47 2008/03/14 17:21:00 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/ChangeLog,v 1.48 2009/02/22 23:15:51 hanno Exp $
+
+*galeon-2.0.7 (22 Feb 2009)
+
+ 22 Feb 2009; Hanno Boeck <hanno@gentoo.org> +galeon-2.0.7.ebuild:
+ Version bump with patches from Fedora, let's galeon compile against latest
+ xulrunner.
14 Mar 2008; Raúl Porcel <armin76@gentoo.org> galeon-2.0.3.ebuild,
galeon-2.0.4.ebuild:
diff --git a/www-client/galeon/galeon-2.0.7.ebuild b/www-client/galeon/galeon-2.0.7.ebuild
new file mode 100644
index 000000000000..8d826e9f9571
--- /dev/null
+++ b/www-client/galeon/galeon-2.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/galeon/galeon-2.0.7.ebuild,v 1.1 2009/02/22 23:15:51 hanno Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
+HOMEPAGE="http://galeon.sourceforge.net"
+SRC_URI="mirror://sourceforge/galeon/${P}.tar.bz2
+ mirror://gentoo/${P}-patches.tar.lzma"
+
+LICENSE="GPL-2"
+IUSE="seamonkey xulrunner"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+RDEPEND=">=net-libs/xulrunner-1.8
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libxml2-2.6.6
+ >=gnome-base/libgnomeui-2.5.2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gnome-desktop-2.10.0
+ >=gnome-base/libglade-2.3.1"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.30
+ >=sys-devel/gettext-0.11"
+
+DOCS="AUTHORS ChangeLog FAQ README README.ExtraPrefs THANKS TODO NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd "${S}"
+ for i in "${WORKDIR}/${P}-patches/*"; do
+ epatch $i || die "patch $i failed"
+ done
+}
+
+src_compile() {
+ myconf="--with-mozilla=libxul-embedding-unstable"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}