summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-08-10 01:28:34 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-08-10 01:28:34 +0000
commitb20927b357b49d889af7ab9e8813cb32888ae1f4 (patch)
tree8992ef41e0a687d548392ee36ea9f4f6de80a433 /www-client
parentCleanup old versions. (diff)
downloadgentoo-2-b20927b357b49d889af7ab9e8813cb32888ae1f4.tar.gz
gentoo-2-b20927b357b49d889af7ab9e8813cb32888ae1f4.tar.bz2
gentoo-2-b20927b357b49d889af7ab9e8813cb32888ae1f4.zip
Switch to bundled ffmpeg for compatibility reasons. See also bug #331661 by Anthony Parsons <ant@specialops.ath.cx>. We are still getting some crashes there. Removed older broken version.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-6.0.472.25-r1.ebuild (renamed from www-client/chromium/chromium-6.0.472.22.ebuild)36
2 files changed, 33 insertions, 13 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 7a7aaca3053d..c15bf49064eb 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.150 2010/08/08 18:41:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.151 2010/08/10 01:28:34 phajdan.jr Exp $
+
+*chromium-6.0.472.25-r1 (10 Aug 2010)
+
+ 10 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-6.0.472.22.ebuild, +chromium-6.0.472.25-r1.ebuild:
+ Switch to bundled ffmpeg for compatibility reasons. See also bug #331661
+ by Anthony Parsons <ant@specialops.ath.cx>. We are still getting some
+ crashes there. Removed older broken version.
08 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
chromium-6.0.472.25.ebuild, chromium-9999.ebuild:
diff --git a/www-client/chromium/chromium-6.0.472.22.ebuild b/www-client/chromium/chromium-6.0.472.25-r1.ebuild
index d19ba5f36efe..39d6e2dd71d1 100644
--- a/www-client/chromium/chromium-6.0.472.22.ebuild
+++ b/www-client/chromium/chromium-6.0.472.25-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.22.ebuild,v 1.1 2010/08/06 03:08:12 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.25-r1.ebuild,v 1.1 2010/08/10 01:28:34 phajdan.jr Exp $
EAPI="2"
@@ -23,7 +23,6 @@ RDEPEND="app-arch/bzip2
>=media-libs/alsa-lib-1.0.19
media-libs/jpeg:0
media-libs/libpng
- media-video/ffmpeg[threads]
cups? ( >=net-print/cups-1.4.4 )
sys-libs/zlib
>=x11-libs/gtk+-2.14.7
@@ -60,16 +59,21 @@ remove_bundled_lib() {
}
src_prepare() {
- # Disable VP8 until we have a recent enough system-provided ffmpeg.
- epatch "${FILESDIR}"/${PN}-disable-vp8-r1.patch
-
- # Workaround for upstream bug http://crbug.com/50678.
- epatch "${FILESDIR}"/${PN}-ffmpeg-compatibility-r0.patch
-
remove_bundled_lib "third_party/bzip2"
+ remove_bundled_lib "third_party/codesighs"
+ remove_bundled_lib "third_party/cros"
+ remove_bundled_lib "third_party/jemalloc"
+ remove_bundled_lib "third_party/lcov"
remove_bundled_lib "third_party/libevent"
remove_bundled_lib "third_party/libjpeg"
remove_bundled_lib "third_party/libpng"
+ remove_bundled_lib "third_party/lzma_sdk"
+ remove_bundled_lib "third_party/molokocacao"
+ remove_bundled_lib "third_party/ocmock"
+ remove_bundled_lib "third_party/py"
+ remove_bundled_lib "third_party/pyftpdlib"
+ remove_bundled_lib "third_party/simplejson"
+ remove_bundled_lib "third_party/tlslite"
# TODO: also remove third_party/libxml and third_party/libxslt when
# http://crbug.com/29333 is fixed.
# TODO: also remove third_party/zlib. For now the compilation fails if we
@@ -87,21 +91,18 @@ src_configure() {
fi
# Use system-provided libraries.
+ # TODO: use_system_ffmpeg (http://crbug.com/50678).
# TODO: use_system_libxml (http://crbug.com/29333).
# TODO: use_system_sqlite (http://crbug.com/22208).
# TODO: use_system_icu, use_system_hunspell (upstream changes needed).
# TODO: use_system_ssl when we have a recent enough system NSS.
myconf="${myconf}
-Duse_system_bzip2=1
- -Duse_system_ffmpeg=1
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_zlib=1"
- # The system-provided ffmpeg supports more codecs. Enable them in chromium.
- myconf="${myconf} -Dproprietary_codecs=1"
-
# The dependency on cups is optional, see bug #324105.
if use cups; then
myconf="${myconf} -Duse_cups=1"
@@ -109,6 +110,14 @@ src_configure() {
myconf="${myconf} -Duse_cups=0"
fi
+ if use gnome; then
+ myconf="${myconf} -Dlinux_link_gnome_keyring=1"
+ else
+ # TODO: we should also disable code trying to dlopen
+ # gnome-keyring in that case.
+ myconf="${myconf} -Dlinux_link_gnome_keyring=0"
+ fi
+
# Enable sandbox.
myconf="${myconf}
-Dlinux_sandbox_path=$(get_chromium_home)/chrome_sandbox
@@ -188,6 +197,9 @@ src_install() {
newman out/Release/chrome.1 chrome.1
newman out/Release/chrome.1 chromium.1
+ doexe out/Release/ffmpegsumo_nolink || die
+ doexe out/Release/libffmpegsumo.so || die
+
# Use system plugins by default.
dosym /usr/$(get_libdir)/nsbrowser/plugins "$(get_chromium_home)/plugins"