summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-10 00:41:50 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-10 00:41:50 +0000
commitc27fbaaf7d57565c9732fd0c81f11c9d406b1ef1 (patch)
treef050f054f378178d7075e14c5732fed02e3b8fe9 /www-client
parentDev channel bump. Add build support for mips, bug 476272; patch by Manuel Lauss. (diff)
downloadgentoo-2-c27fbaaf7d57565c9732fd0c81f11c9d406b1ef1.tar.gz
gentoo-2-c27fbaaf7d57565c9732fd0c81f11c9d406b1ef1.tar.bz2
gentoo-2-c27fbaaf7d57565c9732fd0c81f11c9d406b1ef1.zip
Dev channel bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-29.0.1547.15.ebuild (renamed from www-client/chromium/chromium-29.0.1541.2.ebuild)9
2 files changed, 14 insertions, 3 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 3876ee5e6905..7130f5a9fae1 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.908 2013/07/04 23:10:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.909 2013/07/10 00:41:50 floppym Exp $
+
+*chromium-29.0.1547.15 (10 Jul 2013)
+
+ 10 Jul 2013; Mike Gilbert <floppym@gentoo.org> +chromium-29.0.1547.15.ebuild,
+ -chromium-29.0.1541.2.ebuild:
+ Dev channel bump.
*chromium-28.0.1500.71 (04 Jul 2013)
diff --git a/www-client/chromium/chromium-29.0.1541.2.ebuild b/www-client/chromium/chromium-29.0.1547.15.ebuild
index 22ee5500f418..96bd951debff 100644
--- a/www-client/chromium/chromium-29.0.1541.2.ebuild
+++ b/www-client/chromium/chromium-29.0.1547.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-29.0.1541.2.ebuild,v 1.1 2013/06/20 03:58:52 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-29.0.1547.15.ebuild,v 1.1 2013/07/10 00:41:50 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -144,7 +144,7 @@ src_prepare() {
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
\! -path 'third_party/WebKit/*' \
- \! -path 'third_party/angle/*' \
+ \! -path 'third_party/angle_dx11/*' \
\! -path 'third_party/cacheinvalidation/*' \
\! -path 'third_party/cld/*' \
\! -path 'third_party/cros_system_api/*' \
@@ -350,6 +350,11 @@ src_configure() {
if ! use custom-cflags; then
replace-flags "-Os" "-O2"
strip-flags
+
+ # Prevent linker from running out of address space, bug #471810 .
+ if use x86; then
+ filter-flags "-g*"
+ fi
fi
# Make sure the build system will use the right tools, bug #340795.