summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-03-14 19:57:04 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-03-14 19:57:04 +0000
commit2f2f95bb77ec1f8f65e095678bd446cc64952f5f (patch)
treea7add77fb3f95cb9081db28df51ae020ab325fce /www-misc
parentMarked ~hppa (bug #408119). (diff)
downloadgentoo-2-2f2f95bb77ec1f8f65e095678bd446cc64952f5f.tar.gz
gentoo-2-2f2f95bb77ec1f8f65e095678bd446cc64952f5f.tar.bz2
gentoo-2-2f2f95bb77ec1f8f65e095678bd446cc64952f5f.zip
cleanup, moved paramerte -c to -u in start-stop-daemon
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/xxv/ChangeLog6
-rw-r--r--www-misc/xxv/files/xxv.utf8-v4111
-rw-r--r--www-misc/xxv/files/xxv.utf8-v56
3 files changed, 8 insertions, 115 deletions
diff --git a/www-misc/xxv/ChangeLog b/www-misc/xxv/ChangeLog
index b8eecfe2baf5..497b813df465 100644
--- a/www-misc/xxv/ChangeLog
+++ b/www-misc/xxv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-misc/xxv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/xxv/ChangeLog,v 1.18 2012/02/07 10:37:17 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/xxv/ChangeLog,v 1.19 2012/03/14 19:57:04 hd_brummy Exp $
+
+ 14 Mar 2012; Joerg Bornkessel <hd_brummy@gentoo.org> -files/xxv.utf8-v4,
+ files/xxv.utf8-v5:
+ cleanup, moved paramerte -c to -u in start-stop-daemon
07 Feb 2012; Joerg Bornkessel <hd_brummy@gentoo.org> -xxv-1.4.ebuild,
-xxv-1.5.ebuild, -xxv-1.6.ebuild, xxv-1.6.1.ebuild:
diff --git a/www-misc/xxv/files/xxv.utf8-v4 b/www-misc/xxv/files/xxv.utf8-v4
deleted file mode 100644
index c1f3d0b8ead3..000000000000
--- a/www-misc/xxv/files/xxv.utf8-v4
+++ /dev/null
@@ -1,111 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/www-misc/xxv/files/xxv.utf8-v4,v 1.2 2009/05/02 17:39:39 hd_brummy Exp $
-
-RUNAS_USER="vdr"
-
-# Set Verbose Level 0 -> 5
-VERBOSE="1"
-
-depend() {
- need vdr
-}
-
-# some fixed Path
-CONFIGFILE="/etc/xxv/xxvd.cfg"
-PIDFILE="/var/run/xxv/xxvd.pid"
-XXV_BIN="/usr/bin/xxvd"
-LOGFILE="/var/log/xxv/xxvd.log"
-
-xxv_logger() {
- printf "\tXXV running as user: ${RUNAS_USER}\n" >> "${LOGFILE}"
- printf "\tVerbose Level: ${VERBOSE}\n" >> "${LOGFILE}"
- printf "\tYou can change this in xxv init script\n\n" >> "${LOGFILE}"
-}
-
-check_vdradmin() {
-
- # Check at first, is VDR-Admin running
- # Stopping, while running on same ports
- if [ -n "`netstat -anp | grep vdradmin | grep 8080`" ] ; then
- echo
- eerror "VDR-Admin will Stop at first now"
- eerror "vdradmin and xxv can not run on the same port"
- echo
- /etc/init.d/vdradmin stop
- fi
-}
-
-xxv_kill_pid() {
-
- # After unclear stop, xxvd.pid will not removed, fixed with next line
- if [ ! -x /etc/init.d/root ]; then
- if [ -e ${PIDFILE} -a ! -L /var/lib/init.d/started/xxv ]; then
- rm ${PIDFILE}
- killall xxvd 2> /dev/null
- fi
- fi
-
-}
-
-xxv_kill_initfile() {
-
- # After unclear stop, init file in /var/lib/init.d/started/ still not removed
-
- if [ ! -x /etc/init.d/root ]; then
- if [ -L /var/lib/init.d/started/xxv -a ! -e ${PIDFILE} ]; then
- rm /var/lib/init.d/started/xxv
- /etc/init.d/xxv zap
- killall xxvd 2> /dev/null
- fi
- fi
-
-}
-
-set_utf8_charset() {
- local capfile=/usr/share/vdr/capabilities.sh
- [ -e "${capfile}" ] && . ${capfile}
- if [ "${CAP_UTF8}" = "1" -o "${VDR_CAN_HANDLE_UTF8}" = "yes" ]; then
- # do not clean out utf8
- XXV_UTF8="-utf8"
- printf "\txxv starting with utf-8 support\n" >> "${LOGFILE}"
- fi
-}
-
-start() {
- check_vdradmin
- xxv_logger
- set_utf8_charset
-
- ebegin "Start xxv"
- echo
- einfo "xxv running as user: ${RUNAS_USER}"
- einfo "Verbose Level: ${VERBOSE}"
-
- start-stop-daemon --nicelevel 15 --pidfile ${PIDFILE} --start -c ${RUNAS_USER} --exec ${XXV_BIN} -- \
- ${XXV_UTF8} -configfile=${CONFIGFILE} -verbose=${VERBOSE} -pidfile=${PIDFILE}
- eend $?
-}
-
-
-stop() {
-
- ebegin "Stopping xxvd"
- start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
-
- xxv_kill_pid
- xxv_kill_initfile
-
- eend $?
-}
-
-restart() {
-
- xxv_kill_pid
- xxv_kill_initfile
-
-
- svc_stop
- svc_start
-}
diff --git a/www-misc/xxv/files/xxv.utf8-v5 b/www-misc/xxv/files/xxv.utf8-v5
index 603543f568db..d7d4a9258f2c 100644
--- a/www-misc/xxv/files/xxv.utf8-v5
+++ b/www-misc/xxv/files/xxv.utf8-v5
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/www-misc/xxv/files/xxv.utf8-v5,v 1.1 2009/08/16 18:27:55 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/xxv/files/xxv.utf8-v5,v 1.2 2012/03/14 19:57:04 hd_brummy Exp $
RUNAS_USER="vdr"
@@ -74,7 +74,7 @@ start() {
einfo "xxv running as user: ${RUNAS_USER}"
einfo "Verbose Level: ${VERBOSE}"
- start-stop-daemon --nicelevel 15 --pidfile ${PIDFILE} --start -c ${RUNAS_USER} --exec ${XXV_BIN} -- \
+ start-stop-daemon --nicelevel 15 --pidfile ${PIDFILE} --start -u ${RUNAS_USER} --exec ${XXV_BIN} -- \
-configfile=${CONFIGFILE} -verbose=${VERBOSE} -pidfile=${PIDFILE}
eend $?
}