summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-08 12:35:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-08 12:35:24 +0000
commit077ca70df7c8c1e17ebc6a6659f34d9ace921686 (patch)
tree1fa8911d0e63fa7820fb1cadaa7ea69d8d9acaad /www-servers/monkeyd
parentMove distributed htdocs to doc dir, bug #429632 (diff)
downloadgentoo-2-077ca70df7c8c1e17ebc6a6659f34d9ace921686.tar.gz
gentoo-2-077ca70df7c8c1e17ebc6a6659f34d9ace921686.tar.bz2
gentoo-2-077ca70df7c8c1e17ebc6a6659f34d9ace921686.zip
Add keepdir for empty directories
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog7
-rw-r--r--www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index b77e067e1814..d5d7df977a17 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for www-servers/monkeyd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.43 2012/08/08 12:17:18 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.44 2012/08/08 12:35:24 blueness Exp $
+
+ 08 Aug 2012; Anthony G. Basile <blueness@gentoo.org> monkeyd-1.0.1-r1.ebuild:
+ Add keepdir for empty directories
*monkeyd-1.0.1-r1 (08 Aug 2012)
08 Aug 2012; Anthony G. Basile <blueness@gentoo.org>
+monkeyd-1.0.1-r1.ebuild:
- Move distribution's htdocs to doc dir, bug #429632
+ Move htdocs to docdir, bug #429632
01 Aug 2012; Anthony G. Basile <blueness@gentoo.org> monkeyd-1.0.1.ebuild:
Stable arm, bug #426664
diff --git a/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild b/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild
index d945acd9f833..338b3ceff807 100644
--- a/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild,v 1.1 2012/08/08 12:17:18 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.0.1-r1.ebuild,v 1.2 2012/08/08 12:35:24 blueness Exp $
EAPI="4"
inherit toolchain-funcs depend.php multilib
-WEBROOT="/var/www/localhost"
-
MY_P="${PN/d}-${PV}"
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
@@ -22,6 +20,8 @@ RDEPEND="php? ( virtual/httpd-php )"
S="${WORKDIR}/${MY_P}"
+WEBROOT="/var/www/localhost"
+
pkg_setup() {
use php && require_php_cgi
}
@@ -66,10 +66,13 @@ src_install() {
newinitd "${FILESDIR}"/monkeyd.initd monkeyd
newconfd "${FILESDIR}"/monkeyd.confd monkeyd
+ #move htdocs to docdir, bug #429632
docompress -x /usr/share/doc/"${PF}"/htdocs.dist
-
mv "${D}"${WEBROOT}/htdocs \
"${D}"/usr/share/doc/"${PF}"/htdocs.dist
-
mkdir "${D}"${WEBROOT}/htdocs
+
+ keepdir \
+ /var/log/monkeyd \
+ ${WEBROOT}/htdocs
}