summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-02 18:53:42 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-02 18:53:42 +0000
commit967e299dbfc601e93791383936eb4331d2981942 (patch)
tree448f99533fb515177fb6786967d5ad2b10cac41e /www-servers/nginx
parentFix a silly insinto mistake I made. (diff)
downloadgentoo-2-967e299dbfc601e93791383936eb4331d2981942.tar.gz
gentoo-2-967e299dbfc601e93791383936eb4331d2981942.tar.bz2
gentoo-2-967e299dbfc601e93791383936eb4331d2981942.zip
stabilizing 0.1.26
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.24-r21
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.251
-rw-r--r--www-servers/nginx/files/nginx-0.1.24-upstream_status.patch11
-rw-r--r--www-servers/nginx/nginx-0.1.24-r2.ebuild84
-rw-r--r--www-servers/nginx/nginx-0.1.25.ebuild79
-rw-r--r--www-servers/nginx/nginx-0.1.26.ebuild4
7 files changed, 8 insertions, 179 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 3ec978020d53..5aae2d7ef664 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.11 2005/03/28 14:55:52 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.12 2005/04/02 18:53:42 voxus Exp $
+
+ 02 Apr 2005; Konstantin Arkhipov <voxus@gentoo.org> -nginx-0.1.25.ebuild,
+ -nginx-0.1.24-r2.ebuild, -files/nginx-0.1.24-upstream_status.patch,
+ nginx-0.1.26.ebuild:
+ Cleanups and 0.1.26 now stable on x86 and amd64.
*nginx-0.1.27 (28 Mar 2005)
diff --git a/www-servers/nginx/files/digest-nginx-0.1.24-r2 b/www-servers/nginx/files/digest-nginx-0.1.24-r2
deleted file mode 100644
index 7a8550a38664..000000000000
--- a/www-servers/nginx/files/digest-nginx-0.1.24-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 230358b32da97e42e81165c709e0773b nginx-0.1.24.tar.gz 287825
diff --git a/www-servers/nginx/files/digest-nginx-0.1.25 b/www-servers/nginx/files/digest-nginx-0.1.25
deleted file mode 100644
index 3ff28581fae1..000000000000
--- a/www-servers/nginx/files/digest-nginx-0.1.25
+++ /dev/null
@@ -1 +0,0 @@
-MD5 afc92d951b2b024328d7a0d9002a2ac2 nginx-0.1.25.tar.gz 291125
diff --git a/www-servers/nginx/files/nginx-0.1.24-upstream_status.patch b/www-servers/nginx/files/nginx-0.1.24-upstream_status.patch
deleted file mode 100644
index 7fda2c8cf0d9..000000000000
--- a/www-servers/nginx/files/nginx-0.1.24-upstream_status.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/http/modules/proxy/ngx_http_proxy_upstream.c Sat Mar 5 20:18:50 2005
-+++ src/http/modules/proxy/ngx_http_proxy_upstream.c Wed Mar 9 19:28:54 2005
-@@ -1016,7 +1016,7 @@
- rc = ngx_http_proxy_parse_status_line(p);
-
- if (rc == NGX_AGAIN) {
-- if (p->header_in->pos == p->header_in->last) {
-+ if (p->header_in->last == p->header_in->end) {
- ngx_log_error(NGX_LOG_ERR, rev->log, 0,
- "upstream sent too long status line");
- ngx_http_proxy_next_upstream(p, NGX_HTTP_PROXY_FT_INVALID_HEADER);
diff --git a/www-servers/nginx/nginx-0.1.24-r2.ebuild b/www-servers/nginx/nginx-0.1.24-r2.ebuild
deleted file mode 100644
index e2b1a50480f0..000000000000
--- a/www-servers/nginx/nginx-0.1.24-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.24-r2.ebuild,v 1.2 2005/03/20 14:17:00 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="ssl zlib threads"
-
-DEPEND="dev-lang/perl
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd ${S} && epatch ${FILESDIR}/${P}-upstream_status.patch || die
-}
-
-src_compile() {
- local myconf
-
- use ssl && myconf="${myconf} --with-http_ssl_module"
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use zlib || myconf="${myconf} --without-http_gzip_module"
-
- cd ${S}
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm \
- ${myconf}
-
- emake || "failed to compile"
-}
-
-src_install() {
- cd ${S} || die
-
- dodir /var/log/${PN}
- keepdir /var/log/${PN}
-
- dodir /var/tmp/${PN}
-
- dodir /var/tmp/${PN}/client
- keepdir /var/tmp/${PN}/client
-
- dodir /var/tmp/${PN}/proxy
- keepdir /var/tmp/${PN}/proxy
-
- dodir /var/tmp/${PN}/fastcgi
- keepdir /var/tmp/${PN}/fastcgi
-
- dodir /etc/${PN}
-
- dosbin objs/nginx
- doinitd ${FILESDIR}/nginx
-
- insinto /etc/${PN}
- rm conf/nginx.conf
- doins -r conf/*
- doins ${FILESDIR}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-}
diff --git a/www-servers/nginx/nginx-0.1.25.ebuild b/www-servers/nginx/nginx-0.1.25.ebuild
deleted file mode 100644
index bbe302a0a69c..000000000000
--- a/www-servers/nginx/nginx-0.1.25.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.25.ebuild,v 1.2 2005/03/20 14:17:00 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ssl zlib threads"
-
-DEPEND="dev-lang/perl
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-
-src_compile() {
- local myconf
-
- use ssl && myconf="${myconf} --with-http_ssl_module"
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use zlib || myconf="${myconf} --without-http_gzip_module"
-
- cd ${S}
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm \
- ${myconf}
-
- emake || "failed to compile"
-}
-
-src_install() {
- cd ${S} || die
-
- dodir /var/log/${PN}
- keepdir /var/log/${PN}
-
- dodir /var/tmp/${PN}
-
- dodir /var/tmp/${PN}/client
- keepdir /var/tmp/${PN}/client
-
- dodir /var/tmp/${PN}/proxy
- keepdir /var/tmp/${PN}/proxy
-
- dodir /var/tmp/${PN}/fastcgi
- keepdir /var/tmp/${PN}/fastcgi
-
- dodir /etc/${PN}
-
- dosbin objs/nginx
- doinitd ${FILESDIR}/nginx
-
- insinto /etc/${PN}
- rm conf/nginx.conf
- doins -r conf/*
- doins ${FILESDIR}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-}
diff --git a/www-servers/nginx/nginx-0.1.26.ebuild b/www-servers/nginx/nginx-0.1.26.ebuild
index 497f2f78af17..5693c825defe 100644
--- a/www-servers/nginx/nginx-0.1.26.ebuild
+++ b/www-servers/nginx/nginx-0.1.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.26.ebuild,v 1.1 2005/03/22 16:25:40 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.26.ebuild,v 1.2 2005/04/02 18:53:42 voxus Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="ssl zlib threads"
DEPEND="dev-lang/perl