summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-12-12 20:37:18 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-12-12 20:37:18 +0000
commit2bab8b5d7594f845a17dff014038179fca8721b2 (patch)
tree5ad0d369c65648a3aa224170b1e4b4c008d27497 /www-servers
parentadd myself on metadata (diff)
downloadgentoo-2-2bab8b5d7594f845a17dff014038179fca8721b2.tar.gz
gentoo-2-2bab8b5d7594f845a17dff014038179fca8721b2.tar.bz2
gentoo-2-2bab8b5d7594f845a17dff014038179fca8721b2.zip
Initial commit. Thanks to Johan Bergström (bug #303649)
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/ChangeLog10
-rw-r--r--www-servers/gunicorn/gunicorn-0.11.2.ebuild40
-rw-r--r--www-servers/gunicorn/metadata.xml15
3 files changed, 65 insertions, 0 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
new file mode 100644
index 000000000000..4daf2540077b
--- /dev/null
+++ b/www-servers/gunicorn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-servers/gunicorn
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.1 2010/12/12 20:37:18 rafaelmartins Exp $
+
+*gunicorn-0.11.2 (12 Dec 2010)
+
+ 12 Dec 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.11.2.ebuild, +metadata.xml:
+ Initial commit. Thanks to Johan Bergström (bug #303649)
+
diff --git a/www-servers/gunicorn/gunicorn-0.11.2.ebuild b/www-servers/gunicorn/gunicorn-0.11.2.ebuild
new file mode 100644
index 000000000000..7d7878ed3d4b
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.11.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.11.2.ebuild,v 1.1 2010/12/12 20:37:18 rafaelmartins Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX, fast clients and nothing else"
+HOMEPAGE="http://gunicorn.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/htdocs/*
+ insinto "/usr/share/doc/${PF}"
+ use examples && doins -r examples
+}
+
+src_test() {
+ # distutils_src_test doesn't works if gunicorn isn't installed yet
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" \
+ setup.py test || die 'test failed.'
+ }
+ python_execute_function testing
+}
diff --git a/www-servers/gunicorn/metadata.xml b/www-servers/gunicorn/metadata.xml
new file mode 100644
index 000000000000..ff718e00d981
--- /dev/null
+++ b/www-servers/gunicorn/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX. It's a
+ pre-fork worker model ported from Ruby's Unicorn project. The Gunicorn
+ server is broadly compatible with various web frameworks, simply
+ implemented, light on server resources, and fairly speedy.
+ </longdescription>
+</pkgmetadata>