summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-11-10 21:35:34 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-11-10 21:35:34 +0000
commit3becc5a07f5be6d6d924586ed8629b88ea8aa239 (patch)
tree0a5243b71252e3ab03a42ecb4de567d1295af408 /www-servers
parentChanged the license back to jcraft after of a request from axxo. (diff)
downloadgentoo-2-3becc5a07f5be6d6d924586ed8629b88ea8aa239.tar.gz
gentoo-2-3becc5a07f5be6d6d924586ed8629b88ea8aa239.tar.bz2
gentoo-2-3becc5a07f5be6d6d924586ed8629b88ea8aa239.zip
* bump
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.91
-rw-r--r--www-servers/nginx/nginx-0.3.9.ebuild70
4 files changed, 79 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index d80b4cfea3f4..6c9cb28ef9d3 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.56 2005/11/05 16:20:30 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.57 2005/11/10 21:35:34 voxus Exp $
+
+*nginx-0.3.9 (11 Nov 2005)
+
+ 11 Nov 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.9.ebuild:
+ Version bump.
05 Oct 2005; Konstantin Arkhipov <voxus@gentoo.org> nginx-0.3.7.ebuild:
Stable on x86 and amd64.
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 2617b1465f4c..ba23320fda16 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -2,9 +2,11 @@ MD5 15e25e5b4d73b5e6feb5c27dfbe6c0e7 ChangeLog 9707
MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 86fb37c347608004443f47aabae2fec7 files/digest-nginx-0.2.6 63
MD5 1dc6c0c614d9bb36a95367fdc9cc25c3 files/digest-nginx-0.3.7 63
+MD5 d97eb612489cf6605cfdaffaaeae6e98 files/digest-nginx-0.3.9 63
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 62f46895e63da25c83512f589b9e61cb nginx-0.1.45.ebuild 1935
MD5 6460bce607f17843cd0c22395e6122e0 nginx-0.2.6.ebuild 1934
MD5 cde8245130ff3daccbad17d3d8ce7bcc nginx-0.3.7.ebuild 1934
+MD5 a1cd04a7c9eba7b231a106229af55d82 nginx-0.3.9.ebuild 1936
diff --git a/www-servers/nginx/files/digest-nginx-0.3.9 b/www-servers/nginx/files/digest-nginx-0.3.9
new file mode 100644
index 000000000000..bc4d9e4a43bf
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.9
@@ -0,0 +1 @@
+MD5 d635077b9256c46f2c323cd45825bc76 nginx-0.3.9.tar.gz 340594
diff --git a/www-servers/nginx/nginx-0.3.9.ebuild b/www-servers/nginx/nginx-0.3.9.ebuild
new file mode 100644
index 000000000000..5dd2b235f051
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.9.ebuild,v 1.1 2005/11/10 21:35:34 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}