summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-01-06 16:00:50 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-01-06 16:00:50 +0000
commit0d43049596139192638a275357775849fab1ecc7 (patch)
treed0e77d953be27854e1d491bf7198f79321933b81 /x11-apps/xdm
parentUse multilib_build_binaries helper #489580 by Thomas Sachau. (diff)
downloadgentoo-2-0d43049596139192638a275357775849fab1ecc7.tar.gz
gentoo-2-0d43049596139192638a275357775849fab1ecc7.tar.bz2
gentoo-2-0d43049596139192638a275357775849fab1ecc7.zip
Fix build error with gcc-4.8 and libbsd, bug #474686.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog9
-rw-r--r--x11-apps/xdm/files/xdm-1.1.11-arc4random-include.patch18
-rw-r--r--x11-apps/xdm/files/xdm-1.1.11-setproctitle-include.patch37
-rw-r--r--x11-apps/xdm/xdm-1.1.11-r3.ebuild6
4 files changed, 66 insertions, 4 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index ca877a7811ce..2c8a0fd0e6ea 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.156 2013/10/08 05:03:26 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.157 2014/01/06 16:00:50 chithanh Exp $
+
+ 06 Jan 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xdm-1.1.11-arc4random-include.patch,
+ +files/xdm-1.1.11-setproctitle-include.patch, xdm-1.1.11-r3.ebuild:
+ Fix build error with gcc-4.8 and libbsd, bug #474686.
08 Oct 2013; Agostino Sarubbo <ago@gentoo.org> xdm-1.1.11-r3.ebuild:
Stable for x86, wrt bug #475480
diff --git a/x11-apps/xdm/files/xdm-1.1.11-arc4random-include.patch b/x11-apps/xdm/files/xdm-1.1.11-arc4random-include.patch
new file mode 100644
index 000000000000..db948094b755
--- /dev/null
+++ b/x11-apps/xdm/files/xdm-1.1.11-arc4random-include.patch
@@ -0,0 +1,18 @@
+diff -ur a/xdm/genauth.c b/xdm/genauth.c
+--- a/xdm/genauth.c 2011-09-25 09:35:47.000000000 +0200
++++ b/xdm/genauth.c 2014-01-06 16:28:09.664060603 +0100
+@@ -40,6 +40,14 @@
+
+ #include <errno.h>
+
++#ifdef HAVE_ARC4RANDOM
++# ifdef __linux__
++# include <bsd/stdlib.h>
++# else
++# include <stdlib.h>
++# endif
++#endif
++
+ #include <time.h>
+ #define Time_t time_t
+
diff --git a/x11-apps/xdm/files/xdm-1.1.11-setproctitle-include.patch b/x11-apps/xdm/files/xdm-1.1.11-setproctitle-include.patch
new file mode 100644
index 000000000000..0a3f32bbea02
--- /dev/null
+++ b/x11-apps/xdm/files/xdm-1.1.11-setproctitle-include.patch
@@ -0,0 +1,37 @@
+diff -ur a/xdm/choose.c b/xdm/choose.c
+--- a/xdm/choose.c 2011-09-25 09:35:47.000000000 +0200
++++ b/xdm/choose.c 2014-01-06 16:33:09.628065364 +0100
+@@ -54,6 +54,14 @@
+ # include <tiuser.h>
+ # endif
+
++# ifdef HAVE_SETPROCTITLE
++# ifdef __linux__
++# include <bsd/unistd.h>
++# else
++# include <unistd.h>
++# endif
++# endif
++
+ # include <time.h>
+ # define Time_t time_t
+
+diff -ur a/xdm/session.c b/xdm/session.c
+--- a/xdm/session.c 2011-09-25 09:35:47.000000000 +0200
++++ b/xdm/session.c 2014-01-06 16:40:57.508072789 +0100
+@@ -54,6 +54,15 @@
+ # include <usersec.h>
+ #endif
+
++# ifdef HAVE_SETPROCTITLE
++# include <sys/types.h>
++# ifdef __linux__
++# include <bsd/unistd.h>
++# else
++# include <unistd.h>
++# endif
++# endif
++
+ #ifndef USE_PAM /* PAM modules should handle these */
+ # ifdef SECURE_RPC
+ # include <rpc/rpc.h>
diff --git a/x11-apps/xdm/xdm-1.1.11-r3.ebuild b/x11-apps/xdm/xdm-1.1.11-r3.ebuild
index 0d36d6d42fea..300b5e471524 100644
--- a/x11-apps/xdm/xdm-1.1.11-r3.ebuild
+++ b/x11-apps/xdm/xdm-1.1.11-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.11-r3.ebuild,v 1.10 2013/10/08 05:03:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.11-r3.ebuild,v 1.11 2014/01/06 16:00:50 chithanh Exp $
EAPI=5
@@ -37,6 +37,8 @@ pkg_setup() {
PATCHES=(
"${FILESDIR}"/${PN}-consolekit.patch
"${FILESDIR}"/${P}-cve-2013-2179.patch
+ "${FILESDIR}"/${PN}-1.1.11-arc4random-include.patch
+ "${FILESDIR}"/${PN}-1.1.11-setproctitle-include.patch
)
XORG_CONFIGURE_OPTIONS=(