summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-04-04 00:57:09 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-04-04 00:57:09 +0000
commit075d4a08bd609623d037e4f3b69dbb12655cce4d (patch)
tree734cb403f479f40eae6cf5dac048e1162162a355 /x11-apps/xwininfo
parentReplace open coded strdup with the real thing. Clears a coverity warning. (diff)
downloadgentoo-2-075d4a08bd609623d037e4f3b69dbb12655cce4d.tar.gz
gentoo-2-075d4a08bd609623d037e4f3b69dbb12655cce4d.tar.bz2
gentoo-2-075d4a08bd609623d037e4f3b69dbb12655cce4d.zip
Fix two minor memory leaks.
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'x11-apps/xwininfo')
-rw-r--r--x11-apps/xwininfo/ChangeLog8
-rw-r--r--x11-apps/xwininfo/files/digest-xwininfo-1.0.23
-rw-r--r--x11-apps/xwininfo/xwininfo-1.0.2.ebuild14
3 files changed, 24 insertions, 1 deletions
diff --git a/x11-apps/xwininfo/ChangeLog b/x11-apps/xwininfo/ChangeLog
index 09985681f39e..3d03975065d0 100644
--- a/x11-apps/xwininfo/ChangeLog
+++ b/x11-apps/xwininfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xwininfo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/ChangeLog,v 1.11 2006/02/14 22:03:26 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/ChangeLog,v 1.12 2006/04/04 00:57:09 spyderous Exp $
+
+*xwininfo-1.0.2 (04 Apr 2006)
+
+ 04 Apr 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +xwininfo-1.0.2.ebuild:
+ Fix two minor memory leaks.
14 Feb 2006; Markus Rothe <corsair@gentoo.org> xwininfo-1.0.1.ebuild:
Added ~ppc64
diff --git a/x11-apps/xwininfo/files/digest-xwininfo-1.0.2 b/x11-apps/xwininfo/files/digest-xwininfo-1.0.2
new file mode 100644
index 000000000000..f0993113db86
--- /dev/null
+++ b/x11-apps/xwininfo/files/digest-xwininfo-1.0.2
@@ -0,0 +1,3 @@
+MD5 e5dbc8866a55958297f5f38205b6be1e xwininfo-1.0.2.tar.bz2 91625
+RMD160 f752c86ce5c2fe66ddd6020e926885c227c03e88 xwininfo-1.0.2.tar.bz2 91625
+SHA256 9fdfd3259b335531cdba831872ec0e32c5f6df01e14b87c3187b494be75b7b66 xwininfo-1.0.2.tar.bz2 91625
diff --git a/x11-apps/xwininfo/xwininfo-1.0.2.ebuild b/x11-apps/xwininfo/xwininfo-1.0.2.ebuild
new file mode 100644
index 000000000000..21b1192a6601
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.0.2.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/xwininfo-1.0.2.ebuild,v 1.1 2006/04/04 00:57:09 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xwininfo application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc64 ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"