summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-06-14 11:50:15 +0000
committerMichał Górny <mgorny@gentoo.org>2011-06-14 11:50:15 +0000
commitf8e2669b1685582b34531e3057976cf383ee6ab6 (patch)
tree925b7419a606b5a67e1cab668358236ef80998f6 /x11-apps
parentNow maintained by gnome team, not just me. (diff)
downloadgentoo-2-f8e2669b1685582b34531e3057976cf383ee6ab6.tar.gz
gentoo-2-f8e2669b1685582b34531e3057976cf383ee6ab6.tar.bz2
gentoo-2-f8e2669b1685582b34531e3057976cf383ee6ab6.zip
Use XORG_CONFIGURE_OPTIONS, install a systemd unit file.
(Portage version: 2.2.0_alpha40_p1/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdm/ChangeLog8
-rw-r--r--x11-apps/xdm/files/systemd-service.patch13
-rw-r--r--x11-apps/xdm/xdm-1.1.10-r2.ebuild58
3 files changed, 78 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 119571d42785..f8c285b99f11 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.116 2011/03/05 18:01:50 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.117 2011/06/14 11:50:15 mgorny Exp $
+
+*xdm-1.1.10-r2 (14 Jun 2011)
+
+ 14 Jun 2011; Michał Górny <mgorny@gentoo.org> +xdm-1.1.10-r2.ebuild,
+ +files/systemd-service.patch:
+ Use XORG_CONFIGURE_OPTIONS, install a systemd unit file.
05 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> xdm-1.1.10-r1.ebuild:
ppc64 stable wrt #354237
diff --git a/x11-apps/xdm/files/systemd-service.patch b/x11-apps/xdm/files/systemd-service.patch
new file mode 100644
index 000000000000..ad0e22036dce
--- /dev/null
+++ b/x11-apps/xdm/files/systemd-service.patch
@@ -0,0 +1,13 @@
+--- /dev/null 2011-06-14 08:28:46.818246020 +0200
++++ xdm@.service 2011-06-14 11:19:39.000000000 +0200
+@@ -0,0 +1,10 @@
++[Unit]
++Description=X-Window Display Manager on %I
++Requires=dev-%i.device
++After=dev-%i.device systemd-user-sessions.service
++
++[Service]
++ExecStart=/usr/bin/xdm -nodaemon
++
++[Install]
++Alias=graphical.target.wants/xdm@tty7.service
diff --git a/x11-apps/xdm/xdm-1.1.10-r2.ebuild b/x11-apps/xdm/xdm-1.1.10-r2.ebuild
new file mode 100644
index 000000000000..2c8c63cc8857
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.10-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.10-r2.ebuild,v 1.1 2011/06/14 11:50:15 mgorny Exp $
+
+EAPI=3
+
+inherit multilib xorg-2 pam systemd
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/systemd-service.patch
+ "${FILESDIR}"/xwilling-hang.patch
+)
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession || die
+ if use pam; then
+ # Use system-local-login to get pam_loginuid and pam_ck_connector from
+ # pambase. This is required to get active ConsoleKit session since 0.4.2.
+ pamd_mimic system-local-login xdm auth account session
+ fi
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+
+ systemd_dounit xdm@.service || die
+}