summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2009-03-27 22:24:25 +0000
committerBryan Stine <battousai@gentoo.org>2009-03-27 22:24:25 +0000
commitee6bf130d8ec97296fe93ee7e5197a7cd55e3f12 (patch)
tree80e979d1473ea5a71fdb0ce1283cbea1fbdeb3d9 /x11-base/x11-drm
parentStable for HPPA (bug #258040). (diff)
downloadgentoo-2-ee6bf130d8ec97296fe93ee7e5197a7cd55e3f12.tar.gz
gentoo-2-ee6bf130d8ec97296fe93ee7e5197a7cd55e3f12.tar.bz2
gentoo-2-ee6bf130d8ec97296fe93ee7e5197a7cd55e3f12.zip
Fix linux-mod usage regression, remove nv flag/nouveau module, add ewarn for missing intel. Fixes bug #263259.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'x11-base/x11-drm')
-rw-r--r--x11-base/x11-drm/ChangeLog9
-rw-r--r--x11-base/x11-drm/x11-drm-20090320.ebuild18
2 files changed, 16 insertions, 11 deletions
diff --git a/x11-base/x11-drm/ChangeLog b/x11-base/x11-drm/ChangeLog
index c4a719caf226..dba02a915a4b 100644
--- a/x11-base/x11-drm/ChangeLog
+++ b/x11-base/x11-drm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/x11-drm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.70 2009/03/21 00:23:02 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.71 2009/03/27 22:24:25 battousai Exp $
+
+ 27 Mar 2009; Bryan Stine <battousai@gentoo.org> x11-drm-20090320.ebuild:
+ Removed nouveau.ko and nv VIDEO_CARDS flag. There are no supporting
+ packages in the portage tree for those yet. Fixed linux-mod config check
+ usage regression, bug #263259 (thanks kouyu). Added ewarn for the
+ disappearance of the intel driver, which happened upstream. It's in the
+ kernel now (thanks Andres Sandoval, comment in above bug).
*x11-drm-20090320 (20 Mar 2009)
diff --git a/x11-base/x11-drm/x11-drm-20090320.ebuild b/x11-base/x11-drm/x11-drm-20090320.ebuild
index f7d61dd5e46d..a33e98e57af8 100644
--- a/x11-base/x11-drm/x11-drm-20090320.ebuild
+++ b/x11-base/x11-drm/x11-drm-20090320.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20090320.ebuild,v 1.1 2009/03/21 00:23:02 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20090320.ebuild,v 1.2 2009/03/27 22:24:25 battousai Exp $
inherit eutils x11 linux-mod autotools
IUSE_VIDEO_CARDS="
video_cards_mach64
video_cards_mga
- video_cards_nv
video_cards_r128
video_cards_radeon
video_cards_radeonhd
@@ -46,6 +45,9 @@ DEPEND="kernel_linux? ( virtual/linux-sources )
RDEPEND=""
pkg_setup() {
+ ewarn "The intel DRM module has been removed from x11-drm. Please use the in-kernel"
+ ewarn "DRM module. This package is no longer useful for intel video cards."
+
# Setup the kernel's stuff.
kernel_setup
@@ -131,8 +133,6 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- linux-mod_pkg_setup
-
if kernel_is 2 4
then
eerror "Upstream support for 2.4 kernels has been removed, so this package will no"
@@ -140,11 +140,11 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- linux_chkconfig_builtin "DRM" && \
- die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
-
- CONFIG_CHECK="AGP"
+ CONFIG_CHECK="!DRM AGP"
+ ERROR_DRM="Please disable DRM in the kernel config. (CONFIG_DRM = n)"
ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+
+ linux-mod_pkg_setup
fi
}
@@ -156,8 +156,6 @@ set_vidcards() {
VIDCARDS="${VIDCARDS} mach64.${KV_OBJ}"
use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
- use video_cards_nv && \
- VIDCARDS="${VIDCARDS} nouveau.${KV_OBJ}"
use video_cards_r128 && \
VIDCARDS="${VIDCARDS} r128.${KV_OBJ}"
use video_cards_radeon || use video_cards_radeonhd && \