summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-01-05 03:10:24 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-01-05 03:10:24 +0000
commitee6d116d92fe0dd6101dc06471981cdbde1e8287 (patch)
treefea63c42e1bdf53004cba16e2024a1fce0b29410 /x11-base
parentInitial import. Thanks once again to r1g0 <rigo@home.nl>, bug 23201. (Manifes... (diff)
downloadgentoo-2-ee6d116d92fe0dd6101dc06471981cdbde1e8287.tar.gz
gentoo-2-ee6d116d92fe0dd6101dc06471981cdbde1e8287.tar.bz2
gentoo-2-ee6d116d92fe0dd6101dc06471981cdbde1e8287.zip
Add -momit-leaf-frame-pointer to ALLOWED_FLAGS. Read the gcc man page for why this is cool.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog7
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild3
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild3
3 files changed, 10 insertions, 3 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index 305e5a3a521f..d908f6de6496 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.258 2005/01/05 02:55:18 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.259 2005/01/05 03:10:24 spyderous Exp $
+
+ 04 Jan 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ xorg-x11-6.8.0-r4.ebuild, xorg-x11-6.8.1.901.ebuild:
+ Add -momit-leaf-frame-pointer to ALLOWED_FLAGS. Read the gcc man page for
+ why this is cool.
04 Jan 2005; Donnie Berkholz <spyderous@gentoo.org>;
xorg-x11-6.8.0-r4.ebuild, xorg-x11-6.8.1.901.ebuild:
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild
index 835f3406f8c0..7743febc9525 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild,v 1.38 2005/01/05 02:55:18 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r4.ebuild,v 1.39 2005/01/05 03:10:24 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -483,6 +483,7 @@ cflag_setup() {
ALLOWED_FLAGS="-fstack-protector -march -mcpu -mtune -O -O0 -O1 -O2 -O3 -Os"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -pipe -fomit-frame-pointer"
+ ALLOWED_FLAGS="${ALLOWED_FLAGS} -momit-leaf-frame-pointer"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -g -g0 -g1 -g2 -g3"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -ggdb -ggdb0 -ggdb1 -ggdb2 -ggdb3"
# arch-specific section added by popular demand
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
index 495b09be69ee..ec87cec9b102 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild,v 1.11 2005/01/05 02:55:18 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild,v 1.12 2005/01/05 03:10:24 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -484,6 +484,7 @@ cflag_setup() {
ALLOWED_FLAGS="-fstack-protector -march -mcpu -mtune -O -O0 -O1 -O2 -O3 -Os"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -pipe -fomit-frame-pointer"
+ ALLOWED_FLAGS="${ALLOWED_FLAGS} -momit-leaf-frame-pointer"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -g -g0 -g1 -g2 -g3"
ALLOWED_FLAGS="${ALLOWED_FLAGS} -ggdb -ggdb0 -ggdb1 -ggdb2 -ggdb3"
# arch-specific section added by popular demand