summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-04-13 20:18:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-04-13 20:18:06 +0000
commit8c64ed9364d5aa1becdf7277c2ba03661c5efac0 (patch)
treebd38a0c9d3d361cb061e70b44772c0aadb8ed1e7 /x11-drivers/ati-drivers
parentDrizzt retired, I'll take this. (diff)
downloadgentoo-2-8c64ed9364d5aa1becdf7277c2ba03661c5efac0.tar.gz
gentoo-2-8c64ed9364d5aa1becdf7277c2ba03661c5efac0.tar.bz2
gentoo-2-8c64ed9364d5aa1becdf7277c2ba03661c5efac0.zip
Add patch, fix bug #266029.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/ati-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog6
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild4
-rw-r--r--x11-drivers/ati-drivers/files/8.552/ati-powermode-opt-path-2.patch42
3 files changed, 49 insertions, 3 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index e2c35abfcf82..d6d347ab68e6 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.150 2009/04/13 03:42:48 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.151 2009/04/13 20:18:05 je_fro Exp $
+
+ 13 Apr 2009; Jeff Gardner <je_fro@gentoo.org>
+ +files/8.552/ati-powermode-opt-path-2.patch, ati-drivers-8.552-r2.ebuild:
+ Add patch, fix bug #266029.
13 Apr 2009; Jeff Gardner <je_fro@gentoo.org>
-files/8.476/ati-powermode-opt-path-2.patch:
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild
index cbee8d341b9e..048d6d11001e 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild,v 1.7 2009/04/05 22:26:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.552-r2.ebuild,v 1.8 2009/04/13 20:18:05 je_fro Exp $
IUSE="acpi debug"
@@ -167,7 +167,7 @@ src_unpack() {
|| die "Replacing 'finger' with 'who' failed."
# Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/ and
# add funktion to detect default state.
- epatch "${FILESDIR}"/8.532/ati-powermode-opt-path-2.patch
+ epatch "${FILESDIR}"/${PV}/ati-powermode-opt-path-2.patch
fi
pushd ${MODULE_DIR} >/dev/null
diff --git a/x11-drivers/ati-drivers/files/8.552/ati-powermode-opt-path-2.patch b/x11-drivers/ati-drivers/files/8.552/ati-powermode-opt-path-2.patch
new file mode 100644
index 000000000000..f5a35a304ec4
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/8.552/ati-powermode-opt-path-2.patch
@@ -0,0 +1,42 @@
+diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
+--- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
++++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
+@@ -4,6 +4,8 @@
+ # Control script for ACPI lid state and AC adapter state
+ #
+
++aticonfig='/opt/bin/aticonfig'
++
+ getXuser() {
+ user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
+ if [ x"$user" = x"" ]; then
+@@ -47,7 +49,7 @@
+ done
+
+ #If PPLIB is enabled
+-su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
++su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
+ if [ $? = 0 ]; then
+ echo "Has PPLIB"
+ has_pplib=1
+@@ -61,15 +63,15 @@
+ if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
+ echo "Low power"
+ if [ ${has_pplib} -eq 1 ]; then
+- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
++ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
+ else
+- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
++ su $user -c "$aticonfig --set-powerstate=1"
+ fi
+ else
+ echo "high power"
+ if [ ${has_pplib} -eq 1 ]; then
+- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
++ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
+ else
+- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
++ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
+ fi
+ fi
+