summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-04 17:54:44 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-04 17:54:44 +0000
commitbd0455046aea1c42a54097c127048db24b6cd14e (patch)
treeaf9d88a42e0e0486441acf6425934460e720a908 /x11-drivers/radeon-ucode
parentVersion bump (diff)
downloadgentoo-2-bd0455046aea1c42a54097c127048db24b6cd14e.tar.gz
gentoo-2-bd0455046aea1c42a54097c127048db24b6cd14e.tar.bz2
gentoo-2-bd0455046aea1c42a54097c127048db24b6cd14e.zip
Update for VCE 2.0 firmware
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/radeon-ucode')
-rw-r--r--x11-drivers/radeon-ucode/ChangeLog10
-rw-r--r--x11-drivers/radeon-ucode/radeon-ucode-20140204.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/x11-drivers/radeon-ucode/ChangeLog b/x11-drivers/radeon-ucode/ChangeLog
index 670abd4c372d..fd0ed9d0f7da 100644
--- a/x11-drivers/radeon-ucode/ChangeLog
+++ b/x11-drivers/radeon-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/radeon-ucode
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.35 2013/11/22 18:46:35 chithanh Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/ChangeLog,v 1.36 2014/02/04 17:54:44 chithanh Exp $
+
+*radeon-ucode-20140204 (04 Feb 2014)
+
+ 04 Feb 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +radeon-ucode-20140204.ebuild:
+ Update for VCE 2.0 firmware
*radeon-ucode-20131111 (22 Nov 2013)
diff --git a/x11-drivers/radeon-ucode/radeon-ucode-20140204.ebuild b/x11-drivers/radeon-ucode/radeon-ucode-20140204.ebuild
new file mode 100644
index 000000000000..af1e8c28799a
--- /dev/null
+++ b/x11-drivers/radeon-ucode/radeon-ucode-20140204.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/radeon-ucode/radeon-ucode-20140204.ebuild,v 1.1 2014/02/04 17:54:44 chithanh Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="IRQ microcode for r6xx/r7xx/Evergreen/N.Islands/S.Islands Radeon GPUs and APUs"
+HOMEPAGE="http://people.freedesktop.org/~agd5f/radeon_ucode/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="radeon-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /lib/firmware/radeon
+ FILES=( *.bin )
+ doins ${FILES[@]} || die "doins failed"
+}
+
+pkg_postinst() {
+ if linux_config_exists && linux_chkconfig_builtin DRM_RADEON; then
+ if ! linux_chkconfig_present FIRMWARE_IN_KERNEL || \
+ ! [[ "$(linux_chkconfig_string EXTRA_FIRMWARE)" == *_rlc.bin* ]]; then
+ ewarn "Your kernel has radeon DRM built-in but not the IRQ microcode."
+ ewarn "For kernel modesetting to work, please set in kernel config"
+ ewarn "CONFIG_FIRMWARE_IN_KERNEL=y"
+ ewarn "CONFIG_EXTRA_FIRMWARE_DIR=\"/lib/firmware\""
+ ewarn "CONFIG_EXTRA_FIRMWARE=\"${FILES[@]/#/radeon/}\""
+ ewarn "You may skip microcode files for which no hardware is installed."
+ ewarn "More information at http://wiki.gentoo.org/wiki/Radeon#Firmware"
+ fi
+ fi
+}