summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-02-26 07:51:28 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2009-02-26 07:51:28 +0000
commit6d0b561c303299c778c578944421e3e2adf287c0 (patch)
tree29d3637f15cc4cbcfe0b0dd751c3c5b77dcc47ea /x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6d0b561c303299c778c578944421e3e2adf287c0.tar.gz
gentoo-2-6d0b561c303299c778c578944421e3e2adf287c0.tar.bz2
gentoo-2-6d0b561c303299c778c578944421e3e2adf287c0.zip
Version bump.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
new file mode 100644
index 000000000000..5eda224729ca
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild,v 1.1 2009/02/26 07:51:28 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.5.3
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}