summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-19 16:53:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-19 16:53:52 +0000
commitc169dbc6c7ee5d1668a7b76cefb0f29354a7c313 (patch)
tree61c23463689e32d41ed4a25397d8601ec35a3314 /x11-drivers/xf86-input-virtualbox
parentPossibly broken manifest, be sure. (diff)
downloadgentoo-2-c169dbc6c7ee5d1668a7b76cefb0f29354a7c313.tar.gz
gentoo-2-c169dbc6c7ee5d1668a7b76cefb0f29354a7c313.tar.bz2
gentoo-2-c169dbc6c7ee5d1668a7b76cefb0f29354a7c313.zip
Bump, closes #293556
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-virtualbox')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog14
-rw-r--r--x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig30
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild97
3 files changed, 140 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index 8c3aa9b90ac0..09c86be8b936 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.24 2009/11/10 01:52:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.25 2009/11/19 16:53:51 patrick Exp $
+
+ 19 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.0.12.ebuild,
+ +files/xf86-input-virtualbox-3-localconfig:
+ Bump, closes #293556
+
+*xf86-input-virtualbox-3.0.12 (18 Nov 2009)
+
+ 18 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-3.0.12.ebuild,
+ +files/xf86-input-virtualbox-3-localconfig:
+ Bump
10 Nov 2009; Patrick Lauer <patrick@gentoo.org>
-xf86-input-virtualbox-1.6.6.ebuild, -xf86-input-virtualbox-3.0.6.ebuild:
diff --git a/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig b/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig
new file mode 100644
index 000000000000..535c3f914adf
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/files/xf86-input-virtualbox-3-localconfig
@@ -0,0 +1,30 @@
+# -*- Makefile -*-
+#
+# Overwrite some default kBuild settings
+#
+
+#
+# Copyright (C) 2006-2008 Sun Microsystems, Inc.
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License as published by the Free Software Foundation,
+# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
+# distribution. VirtualBox OSE is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+
+# don't build testcases to save time, they are not needed for the package
+VBOX_WITH_TESTCASES :=
+VBOX_WITH_TESTSUITE :=
+
+KBUILD_MSG_STYLE := brief
+
+## paths, origin, hardening
+VBOX_WITH_HARDENING := 2
+VBOX_WITH_ORIGIN :=
+VBOX_ONLY_ADDITIONS := 1
+
+TEMPLATE_VBOXGUESTR3XF86MOD_LDFLAGS.release =
+TEMPLATE_VBOXGUESTR3XORGMOD_LDFLAGS = $(TEMPLATE_VBOXGUESTR3DLL_LDFLAGS)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild
new file mode 100644
index 000000000000..3b213cbccc66
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-3.0.12.ebuild,v 1.1 2009/11/19 16:53:51 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils multilib
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="x11-base/xorg-server
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-3-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/$(get_libdir)/xorg/modules/input
+
+ # xorg-server-1.6.x
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_16.so vboxmouse_drv.so
+ # xorg-server-1.5.x
+ else
+ newins vboxmouse_drv_15.so vboxmouse_drv.so
+ fi
+
+ # install hal information file about the mouse driver
+ if use hal; then
+ cd "${S}/src/VBox/Additions/linux/installer"
+ insinto /usr/share/hal/fdi/information/20thirdparty
+ doins 90-vboxguest.fdi
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+ if has_version ">=x11-base/xorg-server-1.5" ; then
+ elog "Starting with 1.5 version, X.Org Server can do mouse auto-detection"
+ elog "you may install the hal information file about the mouse driver:"
+ elog ""
+ elog "/usr/share/hal/fdi/information/20thirdparty/90-vboxguest.fdi"
+ elog ""
+ elog "dropping it into: /etc/hal/fdi/policy/"
+ elog ""
+ fi
+}