summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 07:08:32 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 07:08:32 +0000
commit68e18c9df9e30fa7910f6a3987d7ca28668f196c (patch)
tree444b4cdf41137c9b644d774477303bf739e567b5 /x11-drivers/xf86-video-ati
parentadded interim version (bug 72353) and removed broken 5.0.3 version (diff)
downloadgentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.tar.gz
gentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.tar.bz2
gentoo-2-68e18c9df9e30fa7910f6a3987d7ca28668f196c.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-ati/Manifest2
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.61
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6.ebuild24
4 files changed, 37 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
new file mode 100644
index 000000000000..8ad8e500f77c
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-drivers/xf86-video-ati
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.1 2005/08/08 07:08:30 spyderous Exp $
+
+*xf86-video-ati-6.5.6 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +xf86-video-ati-6.5.6.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
new file mode 100644
index 000000000000..3b471b024bb5
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -0,0 +1,2 @@
+MD5 e8455ae80b4bda7eab60ee1e3c92840b xf86-video-ati-6.5.6.ebuild 546
+MD5 73547ec47cd075a80b875b58f9ac3532 files/digest-xf86-video-ati-6.5.6 73
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6
new file mode 100644
index 000000000000..ee9b0e899465
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.6
@@ -0,0 +1 @@
+MD5 bb4ec6a49d4c586112a6181e36fe2840 xf86-video-ati-6.5.6.tar.bz2 620648
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6.ebuild
new file mode 100644
index 000000000000..63da75d913b5
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.6.ebuild,v 1.1 2005/08/08 07:08:30 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~x86"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}