summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-02-03 13:04:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-02-03 13:04:54 +0000
commit39ae71cdea9df300313591064bebc9e907f9c4e2 (patch)
tree45757ab9cf2fcf51e5d3b14531128c23a48ae167 /x11-drivers
parentVersion bump (diff)
downloadgentoo-2-39ae71cdea9df300313591064bebc9e907f9c4e2.tar.gz
gentoo-2-39ae71cdea9df300313591064bebc9e907f9c4e2.tar.bz2
gentoo-2-39ae71cdea9df300313591064bebc9e907f9c4e2.zip
Version bump, comments patch was merged upstream. With thanks to Donnie Berkholz <dberkholz@gentoo.org> for forwarding the release announcement.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild4
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.0.0.ebuild66
3 files changed, 75 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 3d92f4a621bf..71461ca1968f 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.18 2009/01/05 17:45:48 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.19 2009/02/03 13:04:54 chainsaw Exp $
+
+*xf86-input-synaptics-1.0.0 (03 Feb 2009)
+
+ 03 Feb 2009; <chainsaw@gentoo.org> +xf86-input-synaptics-1.0.0.ebuild:
+ Version bump, comments patch was merged upstream. With thanks to Donnie
+ Berkholz <dberkholz@gentoo.org> for forwarding the release announcement.
*xf86-input-synaptics-0.99.3-r1 (05 Jan 2009)
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild
index 71a9b4127585..40ce196b3866 100644
--- a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild,v 1.2 2009/01/06 07:23:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.2-r1.ebuild,v 1.3 2009/02/03 13:04:54 chainsaw Exp $
inherit toolchain-funcs eutils linux-info x-modular
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.0.0.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.0.0.ebuild
new file mode 100644
index 000000000000..bfc357cbdee5
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.0.0.ebuild,v 1.1 2009/02/03 13:04:54 chainsaw Exp $
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="MIT"
+IUSE="hal"
+RDEPEND="x11-libs/libXext
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ !x11-drivers/synaptics
+ x11-base/xorg-server
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_install() {
+ DOCS="INSTALL NEWS TODO README"
+ x-modular_src_install
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+
+ if use hal ; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${S}"/fdi/11-x11-synaptics.fdi
+ fi
+}
+
+pkg_postinst() {
+ einfo "Synaptics settings are now stored in: "
+ einfo "/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ ewarn "You need to migrate your settings and clear them from xorg.conf"
+}