summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-06-06 22:07:08 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-06-06 22:07:08 +0000
commit76b980ef3b1812b7a9e7f1985f0bcd6bca51bdad (patch)
tree3189b6e05a84ae483392be3077cb3eda26256fc9 /x11-drivers
parentBump. Mostly minor fixes. (diff)
downloadgentoo-2-76b980ef3b1812b7a9e7f1985f0bcd6bca51bdad.tar.gz
gentoo-2-76b980ef3b1812b7a9e7f1985f0bcd6bca51bdad.tar.bz2
gentoo-2-76b980ef3b1812b7a9e7f1985f0bcd6bca51bdad.zip
Bump. This reverts a lot of code and goes back to a driver based off the 1.1 series. It's apparently intended to now satisfy the basic input needs instead of doing everything and replacing drivers like synaptics.
(Portage version: 2.1.5.2)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog13
-rw-r--r--x11-drivers/xf86-input-evdev/files/1.99.2/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch40
-rw-r--r--x11-drivers/xf86-input-evdev/files/1.99.2/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch40
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild34
4 files changed, 126 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index 04b53d01f878..fa4ebf102587 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.76 2008/04/09 17:19:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.77 2008/06/06 22:07:08 dberkholz Exp $
+
+*xf86-input-evdev-1.99.2 (06 Jun 2008)
+
+ 06 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.99.2/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.pa
+ tch,
+ +files/1.99.2/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.pat
+ ch, +xf86-input-evdev-1.99.2.ebuild:
+ Bump. This reverts a lot of code and goes back to a driver based off the
+ 1.1 series. It's apparently intended to now satisfy the basic input needs
+ instead of doing everything and replacing drivers like synaptics.
09 Apr 2008; Raúl Porcel <armin76@gentoo.org>
xf86-input-evdev-1.2.0.ebuild:
diff --git a/x11-drivers/xf86-input-evdev/files/1.99.2/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch b/x11-drivers/xf86-input-evdev/files/1.99.2/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch
new file mode 100644
index 000000000000..99135cfb4bc0
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/1.99.2/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch
@@ -0,0 +1,40 @@
+From 15e0091f0b4b0d7dff29da143d405255a1c3bc12 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter@cs.unisa.edu.au>
+Date: Wed, 21 May 2008 16:48:32 +0930
+Subject: [PATCH] Fail if the device cannot be grabbed during the probe.
+
+If the grab fails, this is most likely a sign that the device has been grabbed
+already (probably by a device specified in xorg.conf). So let's not add the
+device to the server's input device list, since it won't generate events
+anyway.
+
+Exception: keyboards and kernel 2.4 are not affected.
+---
+ src/evdev.c | 11 ++++++++---
+ 1 files changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/src/evdev.c b/src/evdev.c
+index e212c14..13f03d3 100644
+--- a/src/evdev.c
++++ b/src/evdev.c
+@@ -901,9 +901,14 @@ EvdevProbe(InputInfoPtr pInfo)
+ int i, has_axes, has_buttons, has_keys;
+ EvdevPtr pEvdev = pInfo->private;
+
+- if (ioctl(pInfo->fd, EVIOCGRAB, (void *)1) && errno == EINVAL) {
+- /* keyboards are unsafe in 2.4 */
+- pEvdev->kernel24 = 1;
++ if (ioctl(pInfo->fd, EVIOCGRAB, (void *)1)) {
++ if (errno == EINVAL) {
++ /* keyboards are unsafe in 2.4 */
++ pEvdev->kernel24 = 1;
++ } else {
++ xf86Msg(X_ERROR, "Grab failed. Device already configured?\n");
++ return 1;
++ }
+ } else {
+ ioctl(pInfo->fd, EVIOCGRAB, (void *)0);
+ }
+--
+1.5.5.1
+
diff --git a/x11-drivers/xf86-input-evdev/files/1.99.2/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch b/x11-drivers/xf86-input-evdev/files/1.99.2/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch
new file mode 100644
index 000000000000..872ea1f0cd65
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/1.99.2/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch
@@ -0,0 +1,40 @@
+From 42422d8f69e6806e1adfd93017cac064a75041c7 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter@cs.unisa.edu.au>
+Date: Mon, 26 May 2008 19:17:19 +0930
+Subject: [PATCH] Check for XINPUT ABI, parameters of InitValuatorClassRec have changed.
+
+---
+ src/evdev.c | 10 ++++++++--
+ 1 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/evdev.c b/src/evdev.c
+index 13f03d3..3fe0708 100644
+--- a/src/evdev.c
++++ b/src/evdev.c
+@@ -726,7 +726,10 @@ EvdevAddAbsClass(DeviceIntPtr device)
+ pEvdev->min_y = absinfo_y.minimum;
+ pEvdev->max_y = absinfo_y.maximum;
+
+- if (!InitValuatorClassDeviceStruct(device, 2, GetMotionHistory,
++ if (!InitValuatorClassDeviceStruct(device, 2,
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
++ GetMotionEvents(),
++#endif
+ GetMotionHistorySize(), Absolute))
+ return !Success;
+
+@@ -756,7 +759,10 @@ EvdevAddRelClass(DeviceIntPtr device)
+
+ pInfo = device->public.devicePrivate;
+
+- if (!InitValuatorClassDeviceStruct(device, 2, GetMotionHistory,
++ if (!InitValuatorClassDeviceStruct(device, 2,
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
++ GetMotionEvents(),
++#endif
+ GetMotionHistorySize(), Relative))
+ return !Success;
+
+--
+1.5.5.1
+
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild
new file mode 100644
index 000000000000..97b658abc23c
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild,v 1.1 2008/06/06 22:07:08 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+#XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86"
+
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ >=sys-apps/hal-0.5.10"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}/${PV}/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch"
+ "${FILESDIR}/${PV}/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch"
+ )
+
+pkg_postinst() {
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+}