summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-06-28 15:18:32 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-06-28 15:18:32 +0000
commitb1899288f3d4b4f973602140722e60795bcb88f2 (patch)
treeee1fd89c019054b84cb2eace255de89c1446d99d /x11-libs/cairo
parentMarked ppc stable for bug #163541. (diff)
downloadgentoo-2-b1899288f3d4b4f973602140722e60795bcb88f2.tar.gz
gentoo-2-b1899288f3d4b4f973602140722e60795bcb88f2.tar.bz2
gentoo-2-b1899288f3d4b4f973602140722e60795bcb88f2.zip
rev bump
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.4.10.ebuild71
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.4.103
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 70ecb33c35c0..6946618f65d4 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.133 2007/06/15 21:55:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.134 2007/06/28 15:18:32 cardoe Exp $
+
+*cairo-1.4.10 (28 Jun 2007)
+
+ 28 Jun 2007; Doug Goldstein <cardoe@gentoo.org> +cairo-1.4.10.ebuild:
+ rev bump
15 Jun 2007; Doug Goldstein <cardoe@gentoo.org>
+files/cairo-1.4.8-XError.patch, cairo-1.4.8.ebuild:
diff --git a/x11-libs/cairo/cairo-1.4.10.ebuild b/x11-libs/cairo/cairo-1.4.10.ebuild
new file mode 100644
index 000000000000..2bd47dfd6760
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.4.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.4.10.ebuild,v 1.1 2007/06/28 15:18:32 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz opengl svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ if use glitz && use opengl; then
+ export glitz_LIBS=-lglitz-glx
+ fi
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable svg) $(use_enable glitz) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.4.10 b/x11-libs/cairo/files/digest-cairo-1.4.10
new file mode 100644
index 000000000000..d15411e43316
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.4.10
@@ -0,0 +1,3 @@
+MD5 5598a5e500ad922e37b159dee72fc993 cairo-1.4.10.tar.gz 3216689
+RMD160 ce1cb025d47ec395577e4f4c6fe5092be85e0cbe cairo-1.4.10.tar.gz 3216689
+SHA256 594e78a66044898c321e378d47faf43b665b23ba638834d2787e344ba13e5132 cairo-1.4.10.tar.gz 3216689