summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-09 13:28:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-09 13:28:22 +0000
commit8f29264fb210dab2379115793743d5851f623a46 (patch)
tree2216fe2c6885bd5507ec0cd9c4382c3800eefb06 /x11-libs/flowcanvas
parentStable on alpha, bug #331022 (diff)
downloadgentoo-2-8f29264fb210dab2379115793743d5851f623a46.tar.gz
gentoo-2-8f29264fb210dab2379115793743d5851f623a46.tar.bz2
gentoo-2-8f29264fb210dab2379115793743d5851f623a46.zip
version bump
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/flowcanvas')
-rw-r--r--x11-libs/flowcanvas/ChangeLog10
-rw-r--r--x11-libs/flowcanvas/flowcanvas-0.6.4.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-libs/flowcanvas/ChangeLog b/x11-libs/flowcanvas/ChangeLog
index 6d631b19c178..2b32e44c8047 100644
--- a/x11-libs/flowcanvas/ChangeLog
+++ b/x11-libs/flowcanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/flowcanvas
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.8 2009/12/12 18:22:03 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.9 2010/10/09 13:28:16 aballier Exp $
+
+*flowcanvas-0.6.4 (09 Oct 2010)
+
+ 09 Oct 2010; Alexis Ballier <aballier@gentoo.org>
+ +flowcanvas-0.6.4.ebuild:
+ version bump
*flowcanvas-0.6.0 (12 Dec 2009)
diff --git a/x11-libs/flowcanvas/flowcanvas-0.6.4.ebuild b/x11-libs/flowcanvas/flowcanvas-0.6.4.ebuild
new file mode 100644
index 000000000000..e89e04c89bb5
--- /dev/null
+++ b/x11-libs/flowcanvas/flowcanvas-0.6.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/flowcanvas-0.6.4.ebuild,v 1.1 2010/10/09 13:28:22 aballier Exp $
+
+EAPI=2
+
+inherit toolchain-funcs multilib eutils
+
+DESCRIPTION="Gtkmm/Gnomecanvasmm widget for boxes and lines environments"
+HOMEPAGE="http://wiki.drobilla.net/FlowCanvas"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-libs/boost
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libgnomecanvasmm-2.6
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig.patch"
+}
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--docs") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog
+}