summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-01-05 10:33:00 +0000
committerPacho Ramos <pacho@gentoo.org>2014-01-05 10:33:00 +0000
commit0b8c5017d51204900eb225ee83c7a7a9ced4b2c7 (patch)
tree7f84cd1d22efbb3fb8122d348c914ed35f98cb84 /x11-libs/goffice
parentDrop vulnerable versions (diff)
downloadgentoo-2-0b8c5017d51204900eb225ee83c7a7a9ced4b2c7.tar.gz
gentoo-2-0b8c5017d51204900eb225ee83c7a7a9ced4b2c7.tar.bz2
gentoo-2-0b8c5017d51204900eb225ee83c7a7a9ced4b2c7.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/ChangeLog9
-rw-r--r--x11-libs/goffice/goffice-0.10.9.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index 4b85e0ca5a27..6a64051d6e08 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/goffice
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.132 2013/12/24 12:33:48 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.133 2014/01/05 10:33:00 pacho Exp $
+
+*goffice-0.10.9 (05 Jan 2014)
+
+ 05 Jan 2014; Pacho Ramos <pacho@gentoo.org> +goffice-0.10.9.ebuild:
+ Version bump
24 Dec 2013; Pacho Ramos <pacho@gentoo.org>
-files/goffice-0.10.4-component.h-backport.patch, -goffice-0.10.7.ebuild,
diff --git a/x11-libs/goffice/goffice-0.10.9.ebuild b/x11-libs/goffice/goffice-0.10.9.ebuild
new file mode 100644
index 000000000000..80f7b6eb294c
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.10.9.ebuild,v 1.1 2014/01/05 10:33:00 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.28:2
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.9:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.2:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# gnome-base/gnome-common
+
+src_configure() {
+ filter-flags -ffast-math
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}