summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-01-24 18:55:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-01-24 18:55:40 +0000
commitb09a59680acda2e36e5841c32eb91cc77494e600 (patch)
treeb0419fefadd5e4731fae2c4eb2cfb35cfbb97e18 /x11-libs/gtkmathview
parentFix tests when Rails 3 components are installed. (diff)
downloadgentoo-2-b09a59680acda2e36e5841c32eb91cc77494e600.tar.gz
gentoo-2-b09a59680acda2e36e5841c32eb91cc77494e600.tar.bz2
gentoo-2-b09a59680acda2e36e5841c32eb91cc77494e600.zip
Clean up old revision. Bump to EAPI 3 for dependencies slot restrictions.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkmathview')
-rw-r--r--x11-libs/gtkmathview/ChangeLog8
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.7.6.ebuild49
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild21
3 files changed, 16 insertions, 62 deletions
diff --git a/x11-libs/gtkmathview/ChangeLog b/x11-libs/gtkmathview/ChangeLog
index 6429950d0ac9..2484484c2064 100644
--- a/x11-libs/gtkmathview/ChangeLog
+++ b/x11-libs/gtkmathview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtkmathview
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.34 2009/05/10 15:53:42 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.35 2011/01/24 18:55:40 eva Exp $
+
+ 24 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ -gtkmathview-0.7.6.ebuild, gtkmathview-0.8.0.ebuild:
+ Clean up old revision. Bump to EAPI 3 for dependencies slot restrictions.
10 May 2009; Samuli Suominen <ssuominen@gentoo.org>
gtkmathview-0.8.0.ebuild, +files/gtkmathview-0.8.0-gcc44.patch:
diff --git a/x11-libs/gtkmathview/gtkmathview-0.7.6.ebuild b/x11-libs/gtkmathview/gtkmathview-0.7.6.ebuild
deleted file mode 100644
index 287fe134b4ad..000000000000
--- a/x11-libs/gtkmathview/gtkmathview-0.7.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.7.6.ebuild,v 1.11 2006/10/14 16:37:36 kloeri Exp $
-
-DESCRIPTION="Rendering engine for MathML documents"
-HOMEPAGE="http://helm.cs.unibo.it/mml-widget/"
-SRC_URI="http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE="gtk svg t1lib"
-
-RDEPEND=">=dev-libs/glib-2.2.1
- >=dev-libs/popt-1.7
- >=dev-libs/libxml2-2.6.7
- gtk? (
- >=x11-libs/gtk+-2.2.1
- >=media-libs/t1lib-5
- >=dev-libs/gmetadom-0.1.8
- x11-libs/pango
- )
- t1lib? ( >=media-libs/t1lib-5 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- # --disable-popt will build only the library and not the frontend
- local myconf="--enable-popt --enable-libxml2 --enable-libxml2-reader"
-
- if use gtk ; then
- myconf="${myconf} --enable-gmetadom"
- fi
-
- # other options
- myconf="${myconf} --enable-builder-cache --enable-breaks --enable-boxml"
-
- econf $(use_enable debug) \
- $(use_enable gtk) $(use_enable gtk gmetadom) \
- $(use_enable svg) \
- $(use_with t1lib) \
- ${myconf} || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "install failed"
- dodoc ANNOUNCEMENT AUTHORS BUGS CONTRIBUTORS ChangeLog HISTORY NEWS TODO
-}
diff --git a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
index a244e8105933..35e37eb3bbe0 100644
--- a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
+++ b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.10 2009/05/10 15:53:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.11 2011/01/24 18:55:40 eva Exp $
+
+EAPI="3"
inherit eutils
@@ -14,11 +16,11 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE="gtk svg t1lib"
-RDEPEND=">=dev-libs/glib-2.2.1
+RDEPEND=">=dev-libs/glib-2.2.1:2
>=dev-libs/popt-1.7
>=dev-libs/libxml2-2.6.7
gtk? (
- >=x11-libs/gtk+-2.2.1
+ >=x11-libs/gtk+-2.2.1:2
>=media-libs/t1lib-5
>=dev-libs/gmetadom-0.1.8
x11-libs/pango
@@ -27,16 +29,13 @@ RDEPEND=">=dev-libs/glib-2.2.1
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-cond-t1.patch
}
-src_compile() {
+src_configure() {
# --disable-popt will build only the library and not the frontend
# TFM is needed for SVG, default value is 2
econf $(use_enable gtk) $(use_enable gtk gmetadom) \
@@ -51,10 +50,10 @@ src_compile() {
--enable-breaks \
--enable-boxml \
|| die "configure failed"
- emake || die "make failed"
}
src_install() {
emake install DESTDIR="${D}" || die "install failed"
- dodoc ANNOUNCEMENT AUTHORS BUGS CONTRIBUTORS ChangeLog HISTORY NEWS TODO
+ dodoc ANNOUNCEMENT AUTHORS BUGS CONTRIBUTORS ChangeLog HISTORY NEWS TODO \
+ || die "dodoc failed"
}