summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-06 16:14:11 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-06 16:14:11 +0000
commit79d22997690c6152703e081dfbe02d9f68076e43 (patch)
tree0087fbe289feda99b4834da7ac1fb6ad6e3f227d /x11-libs/lesstif
parentadded sparc keyword (diff)
downloadgentoo-2-79d22997690c6152703e081dfbe02d9f68076e43.tar.gz
gentoo-2-79d22997690c6152703e081dfbe02d9f68076e43.tar.bz2
gentoo-2-79d22997690c6152703e081dfbe02d9f68076e43.zip
Now installs in /usr/X11R6. See the ChangeLog for a long-winded
description of prophecized motif improvements.
Diffstat (limited to 'x11-libs/lesstif')
-rw-r--r--x11-libs/lesstif/ChangeLog16
-rw-r--r--x11-libs/lesstif/files/digest-lesstif-0.93.36-r31
-rw-r--r--x11-libs/lesstif/lesstif-0.93.36-r3.ebuild73
3 files changed, 89 insertions, 1 deletions
diff --git a/x11-libs/lesstif/ChangeLog b/x11-libs/lesstif/ChangeLog
index d352b1bcc406..d59e4f95ae09 100644
--- a/x11-libs/lesstif/ChangeLog
+++ b/x11-libs/lesstif/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for x11-libs/lesstif
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.7 2003/01/06 15:38:16 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.8 2003/01/06 16:14:11 raker Exp $
+
+*lesstif-0.93.36-r3 (06 Jan 2002)
+
+ 06 Jan 2002; Nick Hadaway <raker@gentoo.org>
+ lesstif-0.93.36-r3.ebuild, files/digest-lesstif-0.93.36-r3 :
+ New ebuild of lesstif which installs into /usr/X11R6 instead of /usr.
+ The next step I envision is the ability to install both lesstif and
+ openmotif and switch between motif implementations i.e. - for testing
+ application compatibility for the brand new wave of lesstif
+ developers with phat gentoo 1.4 systems. :).
+ It has milled in my head for a while now and it will be implemented
+ soon-like. For now, Gentoo 1.4 will be set for you to choose either
+ lesstif or openmotif, not both. Openmotif will install by default if
+ virtual/motif is a dependancy.
*lesstif-0.93.36-r2 (03 Dec 2002)
diff --git a/x11-libs/lesstif/files/digest-lesstif-0.93.36-r3 b/x11-libs/lesstif/files/digest-lesstif-0.93.36-r3
new file mode 100644
index 000000000000..572e657b1cbd
--- /dev/null
+++ b/x11-libs/lesstif/files/digest-lesstif-0.93.36-r3
@@ -0,0 +1 @@
+MD5 bdca805aa4738f45b8fd50f8d37c88b5 lesstif-0.93.36.tar.bz2 2483486
diff --git a/x11-libs/lesstif/lesstif-0.93.36-r3.ebuild b/x11-libs/lesstif/lesstif-0.93.36-r3.ebuild
new file mode 100644
index 000000000000..3759d4eaf1b5
--- /dev/null
+++ b/x11-libs/lesstif/lesstif-0.93.36-r3.ebuild
@@ -0,0 +1,73 @@
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/lesstif-0.93.36-r3.ebuild,v 1.1 2003/01/06 16:14:11 raker Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="An OSF/Motif(R) clone."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.lesstif.org/"
+PROVIDE="virtual/motif"
+LICENSE="LGPL"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}/scripts/autoconf
+ sed -e "/^aclocaldir =/ a DESTDIR = ${D}" \
+ Makefile.in > Makefile.in.hacked
+ mv Makefile.in.hacked Makefile.in || die
+}
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/X11R6 \
+ --sysconfdir=/etc/X11 \
+ --libdir=/usr/X11R6/lib \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-static \
+ --enable-build-12 \
+ --enable-build-20 \
+ --enable-build-21 \
+ --with-x || die "./configure failed"
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+
+ emake prefix=${D}/usr/X11R6 \
+ exec_prefix=${D}/usr/X11R6 \
+ libdir=${D}/usr/X11R6/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dosym /usr/X11R6/lib/libXm.so.2.0.1 /usr/X11R6/lib/libXm.so.1
+
+ # This comes from x11-base/xfree!
+ rm -f ${D}/usr/lib/X11/config/host.def
+
+ dodir /usr/share
+ mv ${D}/usr/X11R6/man ${D}/usr/share/
+ dodir /usr/share/doc/${P}
+ mv ${D}/usr/X11R6/LessTif/* ${D}/usr/share/doc/${P}/
+ # The LessTif directory should be empty now.
+ rmdir ${D}/usr/X11R6/LessTif || die
+}
+
+pkg_postrm() {
+ # Handle if updating removed host.def
+ if [ ! -f ${ROOT}/usr/lib/X11/config/host.def \
+ -a -d ${ROOT}/usr/lib/X11/config ]
+ then
+ touch ${ROOT}/usr/lib/X11/config/host.def
+ fi
+}
+