summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-06-07 21:47:14 +0000
committerRémi Cardona <remi@gentoo.org>2009-06-07 21:47:14 +0000
commitaaacae4af4bc0c89d7ff25d81caced05a05e5a4f (patch)
treec3c155e78722f5a125ee98fe8f50940de0819424 /x11-libs/libX11
parentold (diff)
downloadgentoo-2-aaacae4af4bc0c89d7ff25d81caced05a05e5a4f.tar.gz
gentoo-2-aaacae4af4bc0c89d7ff25d81caced05a05e5a4f.tar.bz2
gentoo-2-aaacae4af4bc0c89d7ff25d81caced05a05e5a4f.zip
x11-libs/libX11: bump to 1.2.1
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/ChangeLog7
-rw-r--r--x11-libs/libX11/libX11-1.2.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-libs/libX11/ChangeLog b/x11-libs/libX11/ChangeLog
index 097048333fc9..ee5617b2cb71 100644
--- a/x11-libs/libX11/ChangeLog
+++ b/x11-libs/libX11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libX11
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.112 2009/05/15 14:51:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.113 2009/06/07 21:47:14 remi Exp $
+
+*libX11-1.2.1 (07 Jun 2009)
+
+ 07 Jun 2009; Rémi Cardona <remi@gentoo.org> +libX11-1.2.1.ebuild:
+ bump to 1.2.1
15 May 2009; Raúl Porcel <armin76@gentoo.org> libX11-1.1.5.ebuild:
arm/m68k/s390 stable
diff --git a/x11-libs/libX11/libX11-1.2.1.ebuild b/x11-libs/libX11/libX11-1.2.1.ebuild
new file mode 100644
index 000000000000..4cf55935c625
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.2.1.ebuild,v 1.1 2009/06/07 21:47:14 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+EAPI="1"
+
+inherit x-modular toolchain-funcs flag-o-matic
+
+DESCRIPTION="X.Org X11 library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 +xcb"
+
+RDEPEND=">=x11-libs/xtrans-1.2.3
+ x11-proto/kbproto
+ >=x11-proto/xproto-7.0.15
+ xcb? ( >=x11-libs/libxcb-1.2 )
+ !xcb? (
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86bigfontproto
+ x11-proto/bigreqsproto
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xcmiscproto
+ >=x11-misc/util-macros-1.2.1"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
+
+src_compile() {
+ x-modular_src_configure
+ # [Cross-Compile Love] Disable {C,LD}FLAGS and redefine CC= for 'makekeys'
+ ( filter-flags -m* ; cd src/util && make CC=$(tc-getBUILD_CC) CFLAGS="${CFLAGS}" LDFLAGS="" clean all)
+ x-modular_src_make
+}