summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-26 17:15:22 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-26 17:15:22 +0000
commit811266519a16905156c2ba39d86e09e66271a626 (patch)
treecdb6577589d8ec5f6d05780cc29b82f5a7d1019b /x11-libs/libXaw
parentRapid stabilization, bug #459124 (diff)
downloadgentoo-2-811266519a16905156c2ba39d86e09e66271a626.tar.gz
gentoo-2-811266519a16905156c2ba39d86e09e66271a626.tar.bz2
gentoo-2-811266519a16905156c2ba39d86e09e66271a626.zip
Enable multilib.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/ChangeLog7
-rw-r--r--x11-libs/libXaw/libXaw-1.0.11-r2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-libs/libXaw/ChangeLog b/x11-libs/libXaw/ChangeLog
index 0f29ddd6e8d0..f86b2191913a 100644
--- a/x11-libs/libXaw/ChangeLog
+++ b/x11-libs/libXaw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libXaw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.118 2013/02/22 19:27:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.119 2013/02/26 17:15:22 mgorny Exp $
+
+*libXaw-1.0.11-r2 (26 Feb 2013)
+
+ 26 Feb 2013; Michał Górny <mgorny@gentoo.org> +libXaw-1.0.11-r2.ebuild:
+ Enable multilib.
22 Feb 2013; Zac Medico <zmedico@gentoo.org> libXaw-1.0.11-r1.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-libs/libXaw/libXaw-1.0.11-r2.ebuild b/x11-libs/libXaw/libXaw-1.0.11-r2.ebuild
new file mode 100644
index 000000000000..44facb1e06b4
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.11-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.11-r2.ebuild,v 1.1 2013/02/26 17:15:22 mgorny Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ x11-libs/libXpm[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/xextproto[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}