summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-27 02:02:32 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-27 02:02:32 +0000
commitb41ff69bee8b528e88e927c0e2b8fdedfaa8d9e5 (patch)
tree6640da4bb219826579f0f3973a7ecd2f9fc2a190 /x11-libs/libcompizconfig/files
parentadd missing mysql to IUSE (diff)
downloadgentoo-2-b41ff69bee8b528e88e927c0e2b8fdedfaa8d9e5.tar.gz
gentoo-2-b41ff69bee8b528e88e927c0e2b8fdedfaa8d9e5.tar.bz2
gentoo-2-b41ff69bee8b528e88e927c0e2b8fdedfaa8d9e5.zip
Added patch to allow the use of system iniparser. Many thanks to Diego E. Pettenò <flameeyes@gentoo.org> for the help with auto-tools.
Dropped ppc/ppc64 keywords until iniparser is keyworded. Fixes bug 259715. (Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libcompizconfig/files')
-rw-r--r--x11-libs/libcompizconfig/files/libcompizconfig-0.8.2-allow-system-libiniparser.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/libcompizconfig/files/libcompizconfig-0.8.2-allow-system-libiniparser.patch b/x11-libs/libcompizconfig/files/libcompizconfig-0.8.2-allow-system-libiniparser.patch
new file mode 100644
index 000000000000..852603ec00ce
--- /dev/null
+++ b/x11-libs/libcompizconfig/files/libcompizconfig-0.8.2-allow-system-libiniparser.patch
@@ -0,0 +1,44 @@
+diff -u -r libcompizconfig-0.8.2-old/configure.ac libcompizconfig-0.8.2/configure.ac
+--- libcompizconfig-0.8.2-old/configure.ac 2009-04-26 12:15:40.000000000 +0000
++++ libcompizconfig-0.8.2/configure.ac 2009-04-26 23:02:14.000000000 +0000
+@@ -116,6 +116,16 @@
+ fi
+ AM_CONDITIONAL([USE_PROTOBUF], [test "x$use_protobuf" = "xyes"])
+
++AC_ARG_WITH(internal-iniparser,
++ [AS_HELP_STRING([--without-internal-iniparser],[Don't use bundled iniparser lib])],
++ [], [with_internal_iniparser=yes])
++
++if test "x$with_internal_iniparser" = "xno"; then
++ AC_CHECK_LIB([iniparser], [iniparser_getnsec], [],
++ [AC_MSG_ERROR([Error! You need to have libiniparser])])
++fi
++AM_CONDITIONAL([WITH_INTERNAL_INIPARSER], [test "x$with_internal_iniparser" = "xyes"])
++
+ AC_CHECK_HEADERS([sys/inotify.h], [have_inotify=yes], [have_inotify=no])
+
+ AC_ARG_ENABLE(debug,
+diff -u -r libcompizconfig-0.8.2-old/src/Makefile.am libcompizconfig-0.8.2/src/Makefile.am
+--- libcompizconfig-0.8.2-old/src/Makefile.am 2009-04-26 12:15:39.000000000 +0000
++++ libcompizconfig-0.8.2/src/Makefile.am 2009-04-26 23:00:37.000000000 +0000
+@@ -39,14 +39,17 @@
+ lists.c \
+ compiz.cpp \
+ config.c \
+- iniparser.c \
+ ini.c \
+ bindings.c \
+ filewatch.c \
+- ccs-private.h \
+- iniparser.h
++ ccs-private.h
+
+ libcompizconfig_la_LIBADD = @LIBXML2_LIBS@ @LIBX11_LIBS@ $(PROTOBUF_LIB)
+
+ lib_LTLIBRARIES=libcompizconfig.la
+
++if WITH_INTERNAL_INIPARSER
++
++ libcompizconfig_la_SOURCES += iniparser.h iniparser.c
++
++endif