summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-09 14:57:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-09 14:57:48 +0000
commit007d5b6c1aa2fcd096a3522b2394bfdc1cda8e45 (patch)
tree0928cb8231edda88fb79bf489b321aec7b662b26 /x11-libs/libmatchbox
parentDrop dvbhead argument, bug 307951 (diff)
downloadgentoo-2-007d5b6c1aa2fcd096a3522b2394bfdc1cda8e45.tar.gz
gentoo-2-007d5b6c1aa2fcd096a3522b2394bfdc1cda8e45.tar.bz2
gentoo-2-007d5b6c1aa2fcd096a3522b2394bfdc1cda8e45.zip
Fix building with libpng14.
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libmatchbox')
-rw-r--r--x11-libs/libmatchbox/ChangeLog8
-rw-r--r--x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch13
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.9.ebuild6
3 files changed, 22 insertions, 5 deletions
diff --git a/x11-libs/libmatchbox/ChangeLog b/x11-libs/libmatchbox/ChangeLog
index a2553cbf2274..cfb26a1369ca 100644
--- a/x11-libs/libmatchbox/ChangeLog
+++ b/x11-libs/libmatchbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libmatchbox
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.12 2009/03/14 04:16:44 solar Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.13 2010/03/09 14:57:48 ssuominen Exp $
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ libmatchbox-1.9.ebuild, +files/libmatchbox-1.9-libpng14.patch:
+ Fix building with libpng14.
14 Mar 2009; <solar@gentoo.org> libmatchbox-1.9.ebuild:
keyword ~amd64
diff --git a/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch
new file mode 100644
index 000000000000..4f87a9bb1b31
--- /dev/null
+++ b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch
@@ -0,0 +1,13 @@
+http://repos.archlinux.org/wsvn/community/libmatchbox/trunk/PKGBUILD
+
+--- libmb/mbpixbuf.c
++++ libmb/mbpixbuf.c
+@@ -228,7 +228,7 @@
+ if ((fd = fopen( file, "rb" )) == NULL) return NULL;
+
+ fread( header, 1, 8, fd );
+- if ( ! png_check_sig( header, 8 ) )
++ if ( ! png_sig_cmp( header, 0, 8 ) )
+ {
+ fclose(fd);
+ return NULL;
diff --git a/x11-libs/libmatchbox/libmatchbox-1.9.ebuild b/x11-libs/libmatchbox/libmatchbox-1.9.ebuild
index 104ecafacbf6..f6d40dc9f739 100644
--- a/x11-libs/libmatchbox/libmatchbox-1.9.ebuild
+++ b/x11-libs/libmatchbox/libmatchbox-1.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 2006-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.9.ebuild,v 1.7 2009/03/14 04:16:44 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.9.ebuild,v 1.8 2010/03/09 14:57:48 ssuominen Exp $
inherit eutils libtool
@@ -36,7 +36,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
-
+ epatch "${FILESDIR}"/${P}-libpng14.patch
elibtoolize
}