summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-20 13:32:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-20 13:32:01 +0000
commit9160b03d4f31b5a9782f454e178ee4d4e4ad954f (patch)
tree89ca6d45a2278b97c1646329c4d8bf6b8a584a51 /x11-libs/qt-dbus
parentUnmask ghc-6.8.2 and related new libs (diff)
downloadgentoo-2-9160b03d4f31b5a9782f454e178ee4d4e4ad954f.tar.gz
gentoo-2-9160b03d4f31b5a9782f454e178ee4d4e4ad954f.tar.bz2
gentoo-2-9160b03d4f31b5a9782f454e178ee4d4e4ad954f.zip
Add a patch that foregoes building qmake and just uses the one from the system
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-libs/qt-dbus')
-rw-r--r--x11-libs/qt-dbus/files/configure.patch12
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild6
2 files changed, 17 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/files/configure.patch b/x11-libs/qt-dbus/files/configure.patch
new file mode 100644
index 000000000000..2e07f6b0cc74
--- /dev/null
+++ b/x11-libs/qt-dbus/files/configure.patch
@@ -0,0 +1,12 @@
+--- configure.orig 2007-12-20 08:22:04.000000000 -0500
++++ configure 2007-12-20 08:22:08.000000000 -0500
+@@ -3615,7 +3615,7 @@
+ }
+
+ # build qmake
+-if true; then ###[ '!' -f "$outpath/bin/qmake" ];
++if false; then ###[ '!' -f "$outpath/bin/qmake" ];
+ echo "Creating qmake. Please wait..."
+
+ OLD_QCONFIG_H=
+
diff --git a/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild b/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild
index efee1b354d2b..2edecf2bf6fa 100644
--- a/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild,v 1.1 2007/12/20 13:16:56 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.4.0_rc1.ebuild,v 1.2 2007/12/20 13:32:00 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -54,6 +54,10 @@ src_unpack() {
ewarn "Appending -fno-stack-protector to CFLAGS/CXXFLAGS"
append-flags -fno-stack-protector
fi
+
+ # Override the creation of qmake and copy over the one from the system. This speeds up compilation time a lot.
+ epatch "${FILESDIR}"/configure.patch
+ cp ${QTBINDIR}/qmake "${S}"/bin/qmake
}
src_compile() {