summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 14:44:04 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 14:44:04 +0000
commitcbb511d962c57902dd3a9aee5d64879fe9fcc750 (patch)
tree98fe86d836b7e2940d205d39a8ad5b78e8c704c7 /x11-libs/qt-declarative
parentVersion bump (diff)
downloadgentoo-2-cbb511d962c57902dd3a9aee5d64879fe9fcc750.tar.gz
gentoo-2-cbb511d962c57902dd3a9aee5d64879fe9fcc750.tar.bz2
gentoo-2-cbb511d962c57902dd3a9aee5d64879fe9fcc750.zip
Version bump
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-declarative')
-rw-r--r--x11-libs/qt-declarative/ChangeLog10
-rw-r--r--x11-libs/qt-declarative/metadata.xml14
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild45
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
new file mode 100644
index 000000000000..8fafe759cc1b
--- /dev/null
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/qt-declarative
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.4 2010/09/21 14:44:04 tampakrap Exp $
+
+*qt-declarative-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-declarative-4.7.0.ebuild, +metadata.xml:
+ Version bump
+
diff --git a/x11-libs/qt-declarative/metadata.xml b/x11-libs/qt-declarative/metadata.xml
new file mode 100644
index 000000000000..e1a08b3f18df
--- /dev/null
+++ b/x11-libs/qt-declarative/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<use>
+ <flag name="private-headers">Install Qt declarative private headers required
+ by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
+ <flag name='exceptions'>Add support for exceptions - like catching them
+ inside the event loop (recommended by Nokia)</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild
new file mode 100644
index 000000000000..9f9f404c2bdb
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild,v 1.1 2010/09/21 14:44:04 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-multimedia-${PV}
+ ~x11-libs/qt-opengl-${PV}
+ ~x11-libs/qt-script-${PV}
+ ~x11-libs/qt-sql-${PV}
+ ~x11-libs/qt-svg-${PV}
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-xmlpatterns-${PV}"
+RDEPEND="${DEPEND}"
+
+QCONFIG_ADD="declarative"
+
+QT4_TARGET_DIRECTORIES="
+ src/declarative
+ tools/qml"
+QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+src_configure() {
+ myconf="${myconf} -declarative"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtDeclarative/private
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}