summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-04 20:54:06 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-04 20:54:06 +0000
commitf8f70b451523b06834259d7b415fcb5ce32b4c10 (patch)
tree97c577b945d0511b1c46c3d56e4a7efb5760485b /x11-libs/qt-script
parentSparc stable, part of Bug #256177. (diff)
downloadgentoo-2-f8f70b451523b06834259d7b415fcb5ce32b4c10.tar.gz
gentoo-2-f8f70b451523b06834259d7b415fcb5ce32b4c10.tar.bz2
gentoo-2-f8f70b451523b06834259d7b415fcb5ce32b4c10.zip
Qt 4.5.0 release version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.5.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 5fba8949cbf8..f4a93a68781a 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.25 2009/02/25 09:25:47 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.26 2009/03/04 20:54:06 yngwin Exp $
+
+*qt-script-4.5.0 (04 Mar 2009)
+
+ 04 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qt-script-4.5.0.ebuild:
+ Version bump
25 Feb 2009; Markos Chandras <hwoarang@gentoo.org>
qt-script-4.5.0_rc1.ebuild:
diff --git a/x11-libs/qt-script/qt-script-4.5.0.ebuild b/x11-libs/qt-script/qt-script-4.5.0.ebuild
new file mode 100644
index 000000000000..17cefde0957d
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.5.0.ebuild,v 1.1 2009/03/04 20:54:06 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}