summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-29 17:08:58 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-29 17:08:58 +0000
commitdf355343f96456c72ff7f0ef6759a95c2180a5ad (patch)
tree71ab58388186c4d371cd3cd227868a110f545aa0 /x11-libs/qt-svg
parentversion bump (diff)
downloadgentoo-2-df355343f96456c72ff7f0ef6759a95c2180a5ad.tar.gz
gentoo-2-df355343f96456c72ff7f0ef6759a95c2180a5ad.tar.bz2
gentoo-2-df355343f96456c72ff7f0ef6759a95c2180a5ad.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog10
-rw-r--r--x11-libs/qt-svg/metadata.xml2
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.0.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 2ca3c0003bf9..bf57447e8629 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-svg
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.97 2011/12/27 21:33:49 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.98 2012/01/29 17:08:58 wired Exp $
+
+*qt-svg-4.8.0 (29 Jan 2012)
+
+ 29 Jan 2012; Alex Alexander <wired@gentoo.org> +qt-svg-4.8.0.ebuild,
+ metadata.xml:
+ version bump
27 Dec 2011; Markus Meier <maekke@gentoo.org> qt-svg-4.7.4.ebuild:
x86 stable, bug #390963
diff --git a/x11-libs/qt-svg/metadata.xml b/x11-libs/qt-svg/metadata.xml
index e34a8eb7ed3e..e68817a72fef 100644
--- a/x11-libs/qt-svg/metadata.xml
+++ b/x11-libs/qt-svg/metadata.xml
@@ -5,5 +5,7 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
+ <flag name='c++0x'>Build Qt using the C++11 standard</flag>
+ <flag name='qpa'>Build a window system agnostic implementation of Qt</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-svg/qt-svg-4.8.0.ebuild b/x11-libs/qt-svg/qt-svg-4.8.0.ebuild
new file mode 100644
index 000000000000..2dd6375e7c32
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.0.ebuild,v 1.1 2012/01/29 17:08:58 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+accessibility iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,qpa=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg/
+ include/Qt/
+ include/QtGui/
+ include/QtCore/
+ include/QtXml/
+ src/corelib/
+ src/gui/
+ src/plugins/
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -svg
+ $(qt_use iconv)
+ $(qt_use accessibility)
+ -no-xkb -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-fontconfig -no-glib -no-gtkstyle"
+ qt4-build_src_configure
+}