summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-03-14 15:13:28 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-03-14 15:13:28 +0000
commit0b99ac1fc5688b439b4b3f26b30b80d377ff0af3 (patch)
treea59ac20584399bb9aaa7affcd19f1eab9e237397 /x11-libs/qwt
parentStop using einfo. (diff)
downloadgentoo-2-0b99ac1fc5688b439b4b3f26b30b80d377ff0af3.tar.gz
gentoo-2-0b99ac1fc5688b439b4b3f26b30b80d377ff0af3.tar.bz2
gentoo-2-0b99ac1fc5688b439b4b3f26b30b80d377ff0af3.zip
More fixes frmo bug 170625
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-libs/qwt')
-rw-r--r--x11-libs/qwt/qwt-5.0.1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/x11-libs/qwt/qwt-5.0.1.ebuild b/x11-libs/qwt/qwt-5.0.1.ebuild
index 13fffcd03a9c..4b9b3cb0fb4f 100644
--- a/x11-libs/qwt/qwt-5.0.1.ebuild
+++ b/x11-libs/qwt/qwt-5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.0.1.ebuild,v 1.2 2007/03/14 12:03:06 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.0.1.ebuild,v 1.3 2007/03/14 15:13:28 caleb Exp $
inherit multilib eutils
@@ -27,7 +27,7 @@ src_unpack () {
echo >> ${qwtconfig} "target.path = /usr/$(get_libdir)"
echo >> ${qwtconfig} "headers.path = /usr/include/qwt5"
echo >> ${qwtconfig} "doc.path = /usr/share/doc/${PF}"
- echo >> ${qwtconfig}
+ echo >> ${qwtconfig}
echo >> ${qwtconfig} "CONFIG += qt warn_on thread"
echo >> ${qwtconfig} "CONFIG += release"
echo >> ${qwtconfig} "CONFIG += QwtDll QwtPlot QwtWidgets QwtDesigner"
@@ -40,15 +40,20 @@ src_unpack () {
# They got the version wrong
sed -e "s/5.0.0/5.0.1/g" -i "${S}/src/src.pro"
+ if ! useq doc; then
+ echo >> "${S}/src/src.pro" "INSTALLS = target headers"
+ fi
+
}
src_compile () {
+ # -j1 due to parallel build failures ( bug # 170625 )
/usr/bin/qmake qwt.pro
- emake || die
+ emake MAKEOPTS="$MAKEOPTS -j1" || die
cd designer
/usr/bin/qmake qwtplugin.pro
- emake || die
+ emake MAKEOPTS="$MAKEOPTS -j1" || die
}
src_install () {