summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-19 21:54:40 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-19 21:54:40 +0000
commitdefdcb62f8ed16f24289abb5a997abe4efa87764 (patch)
tree3cda4000a99fc1a846b43cc60d7ebf971bef7107 /x11-libs/qwtpolar
parentKeep etc/COPYING because C-h C-c needs it. (diff)
downloadgentoo-2-defdcb62f8ed16f24289abb5a997abe4efa87764.tar.gz
gentoo-2-defdcb62f8ed16f24289abb5a997abe4efa87764.tar.bz2
gentoo-2-defdcb62f8ed16f24289abb5a997abe4efa87764.zip
Version Bump
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qwtpolar')
-rw-r--r--x11-libs/qwtpolar/ChangeLog7
-rw-r--r--x11-libs/qwtpolar/qwtpolar-1.0.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/qwtpolar/ChangeLog b/x11-libs/qwtpolar/ChangeLog
index 8ac2965ca37e..37b7308619cf 100644
--- a/x11-libs/qwtpolar/ChangeLog
+++ b/x11-libs/qwtpolar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qwtpolar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/ChangeLog,v 1.5 2011/08/07 12:02:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/ChangeLog,v 1.6 2011/12/19 21:54:40 jlec Exp $
+
+*qwtpolar-1.0.0 (19 Dec 2011)
+
+ 19 Dec 2011; Justin Lecher <jlec@gentoo.org> +qwtpolar-1.0.0.ebuild:
+ Version Bump
07 Aug 2011; Markus Meier <maekke@gentoo.org> qwtpolar-0.1.0-r1.ebuild:
x86 stable, bug #375989
diff --git a/x11-libs/qwtpolar/qwtpolar-1.0.0.ebuild b/x11-libs/qwtpolar/qwtpolar-1.0.0.ebuild
new file mode 100644
index 000000000000..986621f0fb50
--- /dev/null
+++ b/x11-libs/qwtpolar/qwtpolar-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtpolar/qwtpolar-1.0.0.ebuild,v 1.1 2011/12/19 21:54:40 jlec Exp $
+
+EAPI=4
+
+inherit multilib qt4-r2
+
+DESCRIPTION="Library for displaying values on a polar coordinate system"
+HOMEPAGE="http://qwtpolar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="qwt"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qwt:5[svg]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e "/QWT_POLAR_INSTALL_PREFIX /s:=.*$:= ${EPREFIX}/usr:g" \
+ -e "/QWT_POLAR_INSTALL_LIBS/s:lib:$(get_libdir):g" \
+ -e "/QWT_POLAR_INSTALL_DOCS/s:doc:share/doc/${PF}:g" \
+ -e "/QWT_POLAR_INSTALL_PLUGINS/s:=.*$:= ${EPREFIX}/usr/$(get_libdir)/qt4/plugins/designer6/:g" \
+ -e "/QWT_POLAR_INSTALL_FEATURES/s:=.*$:= ${EPREFIX}/usr/$(get_libdir)/qt4/plugins/features6/:g" \
+ -e "/= QwtPolarDesigner/ d" \
+ ${PN}config.pri || die
+
+ sed -i \
+ -e "s:{QWT_POLAR_ROOT}/lib:{QWT_POLAR_ROOT}/$(get_libdir):" \
+ src/src.pro || die
+ echo "INCLUDEPATH += ${EPREFIX}/usr/include/qwt6" >> src/src.pro
+ cat >> designer/designer.pro <<- EOF
+ INCLUDEPATH += "${EPREFIX}"/usr/include/qwt6
+ LIBS += -L"${S}"/$(get_libdir)
+ EOF
+}