summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-06-05 16:44:39 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-06-05 16:44:39 +0000
commit07247350181500d876af087882e39011644ed4dc (patch)
treeef5ba8f76b43cd69c72ee96352e2159e6eba2d66 /x11-libs/vte
parentold (diff)
downloadgentoo-2-07247350181500d876af087882e39011644ed4dc.tar.gz
gentoo-2-07247350181500d876af087882e39011644ed4dc.tar.bz2
gentoo-2-07247350181500d876af087882e39011644ed4dc.zip
Bump to 0.16.5
- Fix issue with 'some strange "underline" line where cursor is located and blinking'. - Misc bug fixes. - Bugs fixed in this release: – Cursor drawn strangely in joe – scrolling vim in full screen is painfully slow and takes up 100% of the cpu – Display glitch with transparent backgroud – ctrl-key combinations yielding just key Original patch by <samo@altern.org> and refactored by Loïc Minier. – gnome-terminal cannot refresh terminal when accessibility enabled Original patch by Li Yuan. – gnome-terminal crashes when open preedit area (Portage version: 2.1.2.9)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog27
-rw-r--r--x11-libs/vte/files/digest-vte-0.16.53
-rw-r--r--x11-libs/vte/vte-0.16.5.ebuild52
3 files changed, 81 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index ba022796587a..bcd745d8722a 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,31 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.156 2007/06/02 02:45:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.157 2007/06/05 16:44:39 dang Exp $
+
+*vte-0.16.5 (05 Jun 2007)
+
+ 05 Jun 2007; Daniel Gryniewicz <dang@gentoo.org> +vte-0.16.5.ebuild:
+ Bump to 0.16.5 - Fix issue with 'some strange "underline" line where cursor
+ is
+
+ located and blinking'. - Misc bug fixes. - Bugs fixed in this release:
+
+ – Cursor drawn strangely in joe
+
+ – scrolling vim in full screen is painfully slow and takes up 100% of the
+ cpu
+
+ – Display glitch with transparent backgroud
+
+ – ctrl-key combinations yielding just key
+
+ Original patch by <samo@altern.org> and refactored by Loïc Minier.
+
+ – gnome-terminal cannot refresh terminal when accessibility enabled
+
+ Original patch by Li Yuan.
+
+ – gnome-terminal crashes when open preedit area
02 Jun 2007; Brent Baude <ranger@gentoo.org> vte-0.14.2.ebuild:
Marking vte-0.14.2 ppc stable for bug #171107
diff --git a/x11-libs/vte/files/digest-vte-0.16.5 b/x11-libs/vte/files/digest-vte-0.16.5
new file mode 100644
index 000000000000..d4bd765716b0
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.16.5
@@ -0,0 +1,3 @@
+MD5 54252b22c7df76e4e1bf8f5a89fe394d vte-0.16.5.tar.bz2 1102926
+RMD160 3941ea10f87e79e8717c8f63df3c4a898ff3aebf vte-0.16.5.tar.bz2 1102926
+SHA256 7965f1a49a72f9be615d5c20ccb0d1376125444c29a669699eccfc7c44b68ba7 vte-0.16.5.tar.bz2 1102926
diff --git a/x11-libs/vte/vte-0.16.5.ebuild b/x11-libs/vte/vte-0.16.5.ebuild
new file mode 100644
index 000000000000..90349dc2778e
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.5.ebuild,v 1.1 2007/06/05 16:44:39 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+ cd ${S}/gnome-pty-helper
+ eautomake
+}