summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-16 12:39:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-16 12:39:17 +0000
commit67ef336b1f435d85a4316d68e8648c57b96001e2 (patch)
tree529b0d495319eec70d78f013f7aa8e6478683e76 /x11-libs/vte
parentBump to 2.4.7. (diff)
downloadgentoo-2-67ef336b1f435d85a4316d68e8648c57b96001e2.tar.gz
gentoo-2-67ef336b1f435d85a4316d68e8648c57b96001e2.tar.bz2
gentoo-2-67ef336b1f435d85a4316d68e8648c57b96001e2.zip
Bump to 0.20.2. Workaround buggy iconv.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog9
-rw-r--r--x11-libs/vte/vte-0.20.2.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 7a2639d3a0fa..348bbf28e129 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.224 2009/05/03 17:24:56 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.225 2009/05/16 12:39:17 eva Exp $
+
+*vte-0.20.2 (16 May 2009)
+
+ 16 May 2009; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.20.2.ebuild:
+ Bump to 0.20.2. Workaround buggy iconv.
*vte-0.20.1 (03 May 2009)
diff --git a/x11-libs/vte/vte-0.20.2.ebuild b/x11-libs/vte/vte-0.20.2.ebuild
new file mode 100644
index 000000000000..953ba277fcea
--- /dev/null
+++ b/x11-libs/vte/vte-0.20.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.20.2.ebuild,v 1.1 2009/05/16 12:39:17 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade python"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.14.0
+ >=x11-libs/pango-1.22.0
+ sys-libs/ncurses
+ glade? ( dev-util/glade:3 )
+ python? ( >=dev-python/pygtk-2.4 )
+ x11-libs/libX11
+ x11-libs/libXft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # backspace broken within screen, bug #249618
+ epatch "${FILESDIR}/${PN}-0.17.4-no-null-backspace.patch"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}