summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-02 01:26:45 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-02 01:26:45 +0000
commit9441b3accafea067ed6bec75b93fc5eaf7683678 (patch)
tree64a151321d2a9ffd2301f452681ffc62aff1f38a /x11-libs
parentver bump #25621 (diff)
downloadgentoo-2-9441b3accafea067ed6bec75b93fc5eaf7683678.tar.gz
gentoo-2-9441b3accafea067ed6bec75b93fc5eaf7683678.tar.bz2
gentoo-2-9441b3accafea067ed6bec75b93fc5eaf7683678.zip
fix DEPEND #34853
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/libast-0.5-r1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-libs/libast/libast-0.5-r1.ebuild b/x11-libs/libast/libast-0.5-r1.ebuild
index e1b01dfcdb60..b89616d381fc 100644
--- a/x11-libs/libast/libast-0.5-r1.ebuild
+++ b/x11-libs/libast/libast-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.4 2003/11/14 15:14:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.5 2003/12/02 01:26:45 vapier Exp $
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -8,19 +8,18 @@ SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc alpha sparc alpha ~mips hppa ~arm"
-IUSE="imlib"
+KEYWORDS="x86 ppc alpha sparc mips alpha arm hppa"
+IUSE="imlib mmx"
DEPEND="virtual/x11
- >=media-libs/freetype-1.3
- imlib? ( media-libs/imlib )"
+ =media-libs/freetype-1*
+ imlib? ( media-libs/imlib2 )"
src_compile() {
- # always disable mmx because binutils-2.11.92+ seems to be broken for this package
- local myconf="--disable-mmx --with-gnu-ld --with-x"
- use imlib && myconf="${myconf} --with-imlib"
-
- econf ${myconf}
+ econf \
+ `use_enable mmx` \
+ `use_with imlib` \
+ || die
emake || die
}