summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-13 00:16:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-13 00:16:53 +0000
commitd81c9b2c3ceaf2565cb1982f02e0b3187eaff08b (patch)
tree92239dfa1668163a26ffc3cc1d9b3b542ef5c16d /x11-libs
parentFixes bug #1638 by adding --disable-perl-regexp. (diff)
downloadgentoo-2-d81c9b2c3ceaf2565cb1982f02e0b3187eaff08b.tar.gz
gentoo-2-d81c9b2c3ceaf2565cb1982f02e0b3187eaff08b.tar.bz2
gentoo-2-d81c9b2c3ceaf2565cb1982f02e0b3187eaff08b.zip
Compile against newer libpng
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog9
-rw-r--r--x11-libs/qt/files/digest-qt-2.3.1-r11
-rw-r--r--x11-libs/qt/files/digest-qt-3.0.2-r11
-rw-r--r--x11-libs/qt/qt-2.3.1-r1.ebuild92
-rw-r--r--x11-libs/qt/qt-3.0.2-r1.ebuild115
5 files changed, 8 insertions, 210 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index f296410fb4ce..fedc55fb0891 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.6 2002/04/03 13:18:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.7 2002/04/13 00:14:33 seemant Exp $
+
+*qt-2.3.2-r1 and qt-3.0.3-r1 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> qt-2.3.2-r1.ebuild
+ qt-3.0.3-r1.ebuild :
+
+ Compile against newer libpng
*qt-2.3.2 (3 Apr 2002)
diff --git a/x11-libs/qt/files/digest-qt-2.3.1-r1 b/x11-libs/qt/files/digest-qt-2.3.1-r1
deleted file mode 100644
index 0541e1798980..000000000000
--- a/x11-libs/qt/files/digest-qt-2.3.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 358d6dfbcbdc353b65b5236866b0f3a7 qt-x11-2.3.1.tar.gz 8967271
diff --git a/x11-libs/qt/files/digest-qt-3.0.2-r1 b/x11-libs/qt/files/digest-qt-3.0.2-r1
deleted file mode 100644
index 867ff4ee2ac1..000000000000
--- a/x11-libs/qt/files/digest-qt-3.0.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 dc9ca180bce53018288ca75d99968bad qt-x11-free-3.0.2.tar.gz 15083583
diff --git a/x11-libs/qt/qt-2.3.1-r1.ebuild b/x11-libs/qt/qt-2.3.1-r1.ebuild
deleted file mode 100644
index 207e3765dda8..000000000000
--- a/x11-libs/qt/qt-2.3.1-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Philippe Namias <pnamias@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.1-r1.ebuild,v 1.1 2002/03/24 22:48:37 danarmak Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="QT ${PV}, an X11 widget set and general library used by KDE et al"
-SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${PV}.tar.gz"
-HOMEPAGE="http://www.trolltech.com/"
-SLOT="2"
-RDEPEND=">=media-libs/libpng-1.0.9
- >=media-libs/libmng-1.0.0
- opengl? ( virtual/opengl virtual/glu )
- nas? ( >=media-libs/nas-1.4.1 )
- virtual/x11"
-
-DEPEND="$RDEPEND
- sys-devel/gcc"
-
-QTBASE=/usr/qt/2
-export QTDIR=${S}
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
-
- cd ${S}/configs
- cp linux-g++-shared linux-g++-shared.orig
- sed -e "s/SYSCONF_CXXFLAGS /SYSCONF_CXXFLAGS = ${CXXFLAGS} \#/" \
- -e "s/SYSCONF_CFLAGS /SYSCONF_CFLAGS = ${CFLAGS} \#/" \
- linux-g++-shared.orig > linux-g++-shared || die
-
-}
-
-src_compile() {
-
- export LDFLAGS="$LDFLAGS -ldl"
- local myconf
-
- use opengl || myconf="$myconf -no-opengl"
- use nas && myconf="${myconf} -system-nas-sound" || myconf="${myconf} -no-nas-sound"
- use gif && myconf="${myconf} -gif"
- [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release"
-
- ./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
- -system-libmng -system-libpng -gif -platform linux-g++ \
- -ldl -lpthread -no-g++-exceptions || die
-
- cd ${S}
- make symlinks src-moc sub-src sub-tools || die
-
-}
-
-src_install() {
-
- cd ${S}
-
- # binaries
- into $QTBASE
- dobin bin/*
-
- # libraries
- dolib lib/libqt.so.${PV} lib/libqt-mt.so.${PV} lib/libqutil.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqt.so libqt-mt.so
- do
- ln -s $x.2.3.1 $x.2.3
- ln -s $x.2.3 $x.2
- ln -s $x.2 $x
- done
- ln -s libqutil.so.1.0.0 libqutil.so.1.0
- ln -s libqutil.so.1.0 libqutil.so.1
- ln -s libqutil.so.1 libqutil.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include
- cp include/* ${D}/${QTBASE}/include/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{50qt2,45qtdir2}
-
-}
-
-
-
-
diff --git a/x11-libs/qt/qt-3.0.2-r1.ebuild b/x11-libs/qt/qt-3.0.2-r1.ebuild
deleted file mode 100644
index 7cadbd9d5b04..000000000000
--- a/x11-libs/qt/qt-3.0.2-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.2-r1.ebuild,v 1.1 2002/03/24 22:48:37 danarmak Exp $
-
-P=qt-x11-${PV}
-S=${WORKDIR}/qt-x11-free-${PV}
-
-DESCRIPTION="QT version ${PV}"
-SLOT="3"
-SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
-HOMEPAGE="http://www.trolltech.com/"
-
-DEPEND=">=media-libs/libpng-1.0.9
- >=media-libs/libmng-1.0.0
- opengl? ( virtual/opengl virtual/glu )
- nas? ( >=media-libs/nas-1.4.1 )
- mysql? ( >=dev-db/mysql-3.2.10 )
- postgres? ( =dev-db/postgresql-7.1.3* )
- odbc? ( >=dev-db/unixODBC-2.0 )
- virtual/x11"
-
-QTBASE=/usr/qt/3
-export QTDIR=${S}
-
-src_unpack() {
-
- export QTDIR=${S}
-
- unpack ${A}
-
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
-
-}
-
-src_compile() {
-
- export QTDIR=${S}
-
- export LDFLAGS="-ldl"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif"
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
- use odbc && myconf="${myconf} -plugin-sql-odbc"
- [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
-
- # avoid wasting time building things we won't install
- rm -rf tutorial examples
-
- ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
- -system-libmng -system-libpng -ldl -lpthread -xft || die
-
- export QTDIR=${S}
-
- emake src-qmake src-moc sub-src sub-tools || die
-
-}
-
-src_install() {
-
-
- export QTDIR=${S}
-
- cd ${S}
-
- # binaries
- into $QTBASE
- dobin bin/*
-
- # libraries
- dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqui.so libeditor.so
- do
- ln -s $x.1.0.0 $x.1.0
- ln -s $x.1.0 $x.1
- ln -s $x.1 $x
- done
- ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
- ln -s libqt-mt.so.3.0 libqt-mt.so.3
- ln -s libqt-mt.so.3 libqt-mt.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include/private
- cp include/* ${D}/${QTBASE}/include/
- cp include/private/* ${D}/${QTBASE}/include/private/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{45qt3,50qtdir3}
-
- # misc build reqs
- dodir ${QTBASE}/mkspecs
- cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
-
- sed -e "s:${D}::g" \
- -e "s:qt-x11-free-3.0.1::g" \
- -e "s:${WORKDIR}:${QTBASE}:" \
- -e "s:/usr/local/qt:${QTBASE}:" \
- ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
-
- # plugins
- cd ${S}
- plugins=`find plugins -name "lib*.so" -print`
- for x in $plugins; do
- insinto ${QTBASE}/`dirname $x`
- doins $x
- done
-
-}