summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-24 21:57:54 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-24 21:57:54 +0000
commitef291b2b359125574afb62f0e25cb7c781d67fa0 (patch)
tree808ce33ba87b4ca6f68a11037cbca2c2e290a1af /x11-libs
parentremoved >app-portage/mirrorselect. New version is unleashed on ~arch (diff)
downloadgentoo-2-ef291b2b359125574afb62f0e25cb7c781d67fa0.tar.gz
gentoo-2-ef291b2b359125574afb62f0e25cb7c781d67fa0.tar.bz2
gentoo-2-ef291b2b359125574afb62f0e25cb7c781d67fa0.zip
fixed use flags
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/ChangeLog5
-rw-r--r--x11-libs/fltk/fltk-1.1.6.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index dac049929762..f1a6496ff8bc 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/fltk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.46 2005/06/22 10:40:24 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.47 2005/06/24 21:57:54 smithj Exp $
+
+ 24 Jun 2005; Jonathan Smith <smithj@gentoo.org> fltk-1.1.6.ebuild:
+ fixed use flags
22 Jun 2005; Herbie Hopkins <herbs@gentoo.org> fltk-1.1.6.ebuild:
Add multilib fix to this version too.
diff --git a/x11-libs/fltk/fltk-1.1.6.ebuild b/x11-libs/fltk/fltk-1.1.6.ebuild
index 1cc03f0df82a..df8eb9837b0e 100644
--- a/x11-libs/fltk/fltk-1.1.6.ebuild
+++ b/x11-libs/fltk/fltk-1.1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.6.ebuild,v 1.2 2005/06/22 10:40:24 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.6.ebuild,v 1.3 2005/06/24 21:57:54 smithj Exp $
-IUSE="X opengl debug"
+IUSE="noxft opengl debug"
inherit eutils toolchain-funcs multilib
@@ -39,7 +39,7 @@ src_compile() {
local myconf
myconf="--enable-shared --enable-xdbe --enable-static --enable-threads"
- if use X; then
+ if ! use noxft; then
myconf="${myconf} --enable-xft"
else
myconf="${myconf} --disable-xft"
@@ -86,3 +86,8 @@ src_install() {
mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
rmdir ${D}/usr/share/doc/fltk
}
+
+pkg_postinst() {
+ ewarn "the xft USE flag has been changed to noxft. this was because most"
+ ewarn "users want xft, but if you do not, be sure to change the flag"
+}