summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-07 08:05:06 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-07 08:05:06 +0000
commitf249605d2f9279403f259b4aeebd63852c2f3992 (patch)
tree576bd7352260ed6a319abe5aeba0053418292c6a /x11-libs
parentreplace a cp command with insinto/doins (diff)
downloadgentoo-2-f249605d2f9279403f259b4aeebd63852c2f3992.tar.gz
gentoo-2-f249605d2f9279403f259b4aeebd63852c2f3992.tar.bz2
gentoo-2-f249605d2f9279403f259b4aeebd63852c2f3992.zip
The new qt moves to live in /usr. Therefore we don't use QTDIR anymore.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-x11/files/digest-qt-x11-2.3.1-r12
-rw-r--r--x11-libs/qt-x11/qt-x11-2.3.1-r1.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/x11-libs/qt-x11/files/digest-qt-x11-2.3.1-r1 b/x11-libs/qt-x11/files/digest-qt-x11-2.3.1-r1
new file mode 100644
index 000000000000..80b6a581c27e
--- /dev/null
+++ b/x11-libs/qt-x11/files/digest-qt-x11-2.3.1-r1
@@ -0,0 +1,2 @@
+MD5 54ea141dc13ba9fca00d0202429f6ec9 qt-configs.patch
+MD5 358d6dfbcbdc353b65b5236866b0f3a7 qt-x11-2.3.1.tar.gz
diff --git a/x11-libs/qt-x11/qt-x11-2.3.1-r1.ebuild b/x11-libs/qt-x11/qt-x11-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..f03a681f202d
--- /dev/null
+++ b/x11-libs/qt-x11/qt-x11-2.3.1-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-2.3.1-r1.ebuild,v 1.1 2001/10/07 08:05:06 danarmak Exp $
+# note: this is the new revision that installs into /usr
+
+S=${WORKDIR}/qt-${PV}
+DESCRIPTION="QT ${PV}"
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/${P}.tar.gz \
+http://www.research.att.com/~leonb/objprelink/qt-configs.patch"
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND=">=media-libs/libpng-1.0.9
+ >=media-libs/libmng-1.0.0
+ opengl? ( virtual/opengl virtual/glu )
+ nas? ( >=media-sound/nas-1.4.1 )
+ objprelink? ( dev-util/objprelink )
+ virtual/x11"
+
+export QTDIR=${S}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ if [ "`use objprelink`" ]
+ then
+ patch -p0 < ${DISTDIR}/qt-configs.patch
+ fi
+}
+
+src_compile() {
+
+ export LDFLAGS="-ldl"
+ local myconf
+
+ if [ -z "`use opengl`" ]
+ then
+ myconf="-no-opengl"
+ fi
+
+ if [ "`use nas`" ]
+ then
+ myconf="${myconf} -system-nas-sound"
+ else
+ myconf="${myconf} -no-nas-sound"
+ fi
+
+ if [ "`use gif`" ]
+ then
+ myconf="${myconf} -gif"
+ fi
+
+ if [ "$DEBUG" ]
+ then
+ myconf="${myconf} -debug"
+ else
+ myconf="${myconf} -release"
+ fi
+
+ SYSCONF_CFLAGS="$CFLAGS" SYSCONF_CXXFLAGS="$CXXFLAGS" \
+ ./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
+ -system-libmng -system-libpng -gif -platform linux-g++ \
+ -ldl -lpthread -no-g++-exceptions || die
+
+ cd ${S}
+ make SYSCONF_CFLAGS="$CFLAGS" SYSCONF_CXXFLAGS="$CXXFLAGS" \
+ symlinks src-moc src-mt sub-src sub-tools || die
+
+ # leave out src-tools for testing !
+}
+
+src_install() {
+
+ QTBASE=/usr
+ cd ${S}
+ into $QTBASE
+ dobin bin/*
+ dolib.so lib/libqt.so.${PV}
+ dolib.so lib/libqt-mt.so.${PV}
+ dolib.so lib/libqutil.so.1.0.0
+ preplib $QTBASE
+ dosym libqt.so.${PV} $QTBASE/lib/libqt.so
+ dosym libqt-mt.so.${PV} $QTBASE/lib/libqt-mt.so
+ dosym libqutil.so.1.0.0 $QTBASE/lib/libqutil.so
+ cd ${S}
+ dodir ${QTBASE}/include
+ cp include/* ${D}${QTBASE}/include/
+ doman doc/man/man3/*
+
+ dodoc ANNOUNCE FAQ LICENSE.QPL MANIFEST PLATFORMS
+ dodoc PORTING README*
+ cp -af ${S}/doc/html ${D}/usr/doc/${P}
+
+}
+
+
+
+