summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2004-05-27 20:14:23 +0000
committerFerris McCormick <fmccor@gentoo.org>2004-05-27 20:14:23 +0000
commit81207c278e1b402edfd6eebbe02fd5377eeaa2f2 (patch)
tree6ddfb8d92d0747de1b99213c63f09debae3f765d /x11-misc/afbinit/afbinit-1.0.1-r2.ebuild
parentAdded v4l2 use flag for mpeg4ip-1.1 (diff)
downloadgentoo-2-81207c278e1b402edfd6eebbe02fd5377eeaa2f2.tar.gz
gentoo-2-81207c278e1b402edfd6eebbe02fd5377eeaa2f2.tar.bz2
gentoo-2-81207c278e1b402edfd6eebbe02fd5377eeaa2f2.zip
Add code to detect afb (Elite frame buffer) when using 2.6.x kernel.
Diffstat (limited to 'x11-misc/afbinit/afbinit-1.0.1-r2.ebuild')
-rw-r--r--x11-misc/afbinit/afbinit-1.0.1-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/afbinit/afbinit-1.0.1-r2.ebuild b/x11-misc/afbinit/afbinit-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..a1adacec2468
--- /dev/null
+++ b/x11-misc/afbinit/afbinit-1.0.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/afbinit/afbinit-1.0.1-r2.ebuild,v 1.1 2004/05/27 20:14:23 fmccor Exp $
+
+inherit eutils
+
+DESCRIPTION="loads the microcode for Elite3D framebuffers to use X"
+HOMEPAGE="I dont have a home :("
+SRC_URI="http://cvs.gentoo.org/~weeve/files/${P}.tar.bz2"
+IUSE=""
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="-* -sparc"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ ##
+ # Patch rc.afb to handle both kernels 2.4.x and 2.6.x
+ einfo "Patching to handle both kernel 2.4.x and 2.6.x style afb identification"
+ cd ${S}
+ epatch ${FILESDIR}/rc.afb-${PVR}.patch || die "Cannot patch rc.afb init script"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ dosbin afbinit
+ dosbin rc.afb
+ exeinto /etc/init.d ; newexe ${FILESDIR}/afbinit.init afbinit
+}
+
+pkg_postinst() {
+ einfo "To use afbinit, you'll need the AFB microcode."
+ einfo "This is available via a Solaris install at /usr/lib/afb.ucode"
+ einfo "or via sun.com"
+}