summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-03-17 10:01:25 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-03-17 10:01:25 +0000
commit1e42736b395c579779be170272da4cae7819dea0 (patch)
tree5ad7b2f293ef232577d82d7484871722ad985182 /x11-misc/icets/icets-1.0.ebuild
parentrev bump for ppc support (diff)
downloadgentoo-2-1e42736b395c579779be170272da4cae7819dea0.tar.gz
gentoo-2-1e42736b395c579779be170272da4cae7819dea0.tar.bz2
gentoo-2-1e42736b395c579779be170272da4cae7819dea0.zip
new version
Diffstat (limited to 'x11-misc/icets/icets-1.0.ebuild')
-rw-r--r--x11-misc/icets/icets-1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/icets/icets-1.0.ebuild b/x11-misc/icets/icets-1.0.ebuild
new file mode 100644
index 000000000000..6d95846ba0a8
--- /dev/null
+++ b/x11-misc/icets/icets-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icets/icets-1.0.ebuild,v 1.1 2003/03/17 10:01:25 phosphan Exp $
+
+DESCRIPTION="IceWM Theme Editor"
+SRC_URI="http://tsa.dyndns.org/mirror/xvadim/${P}.tar.bz2"
+HOMEPAGE="http://tsa.dyndns.org/mirror/xvadim/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=qt-3.0.0"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/${PN}
+
+ # Change the default directory that it looks into to be consistent
+ # with Gentoo's layout
+ cp icets.cpp icets.cpp.orig
+ sed "s:/usr/local/share/icewm/themes:/usr/share/icewm/themes:" \
+ icets.cpp.orig > icets.cpp
+}
+
+src_compile () {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ rm -rf ${D}/usr/doc
+ dohtml icets/docs/en/*.{html,sgml}
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}