summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-05-10 18:56:10 +0000
committerBryan Stine <battousai@gentoo.org>2004-05-10 18:56:10 +0000
commit7c06371a880c427c4be5c0d646de7df919474894 (patch)
tree1f26903cb3d19220186ddf0cfe2dfc36a7194879 /x11-misc/linuxwacom
parentVersion bump, fixes bug 49862. (Manifest recommit) (diff)
downloadgentoo-2-7c06371a880c427c4be5c0d646de7df919474894.tar.gz
gentoo-2-7c06371a880c427c4be5c0d646de7df919474894.tar.bz2
gentoo-2-7c06371a880c427c4be5c0d646de7df919474894.zip
Fixes
Diffstat (limited to 'x11-misc/linuxwacom')
-rw-r--r--x11-misc/linuxwacom/ChangeLog5
-rw-r--r--x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild56
2 files changed, 51 insertions, 10 deletions
diff --git a/x11-misc/linuxwacom/ChangeLog b/x11-misc/linuxwacom/ChangeLog
index a60eb1db433e..b8807f37de53 100644
--- a/x11-misc/linuxwacom/ChangeLog
+++ b/x11-misc/linuxwacom/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/linuxwacom
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.4 2004/05/10 18:48:44 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.5 2004/05/10 18:56:10 battousai Exp $
+
+ 10 May 2004; Bryan Stine <battousai@gentoo.org>; linuxwacom-0.6.2.ebuild:
+ Patched ebuild. Also, pedantic spacing fixes.
*linuxwacom-0.6.2 (10 May 2004)
diff --git a/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
index 342bea0a0022..0bd3e9fad1d3 100644
--- a/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
+++ b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild,v 1.1 2004/05/10 18:48:44 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild,v 1.2 2004/05/10 18:56:10 battousai Exp $
DESCRIPTION="Input driver for Wacom tablets and drawing devices"
HOMEPAGE="http://linuxwacom.sourceforge.net/"
@@ -8,16 +8,35 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="gtk gtk2 tcltk"
-DEPEND="|| ( >=x11-base/xfree-4.3.0-r6 x11-base/xorg-x11 )"
+RDEPEND="|| ( >=x11-base/xfree-4.3.0-r6 x11-base/xorg-x11 )
+ gtk? (
+ gtk2? ( >=x11-libs/gtk+-2 ) : ( =x11-libs/gtk-1.2* )
+ )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ dev-util/pkgconfig"
pkg_setup() {
- if [ ! "`grep sdk /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
+ if has_version ">=x11-base/xfree-4.3.0-r6"
then
- eerror "This package builds against the XFree86 SDK, and therefore requires"
- eerror "that you have emerged xfree with the sdk USE flag enabled."
- die "Please remerge xfree with the sdk USE flag enabled."
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
+ then
+ eerror "This package builds against the XFree86 SDK, and therefore requires"
+ eerror "that you have emerged xfree with the sdk USE flag enabled."
+ die "Please remerge xfree with the sdk USE flag enabled."
+ fi
+ else
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
+ then
+ eerror "This package builds against the X.Org SDK, and therefore requires"
+ eerror "that you have emerged xorg-x11 with the sdk USE flag enabled."
+ die "Please remerge xorg-x11 with the sdk USE flag enabled."
+ fi
fi
}
@@ -31,8 +50,25 @@ src_unpack() {
}
src_compile() {
- myconf="--enable-wacomdrv --enable-wacomdrvv3 --with-xf86=/usr/X11R6/lib/Server \
- --with-xf86v3=/usr/X11R6/lib/Server"
+ if [ `use gtk` ];
+ then
+ if [ `use gtk2` ];
+ then
+ withgtk="--with-gtk=2.0"
+ else
+ withgtk="--with-gtk=1.2"
+ fi
+ else
+ withgtk="--with-gtk=no"
+ fi
+ if [ `use tcltk` ];
+ then
+ withtcltk="--with-tcl --with-tk"
+ else
+ withtcltk="--without-tcl --without-tk"
+ fi
+
+ myconf="--enable-wacomdrv --with-xf86=/usr/X11R6/lib/Server $withgtk $withtcltk"
econf ${myconf} || die "configure failed."
# Makefile fix for build against SDK
@@ -48,4 +84,6 @@ src_compile() {
src_install() {
emake DESTDIR=${D} install || die "Install failed."
+ dohtml -r docs/*
+ dodoc AUTHORS ChangeLog NEWS README
}