summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-05-11 09:09:00 +0000
committerBen de Groot <yngwin@gentoo.org>2012-05-11 09:09:00 +0000
commitd1644c677ba06264228706a7683400a765e7d626 (patch)
tree42a59d0fdbbd4f355ee2fce21fa5a69b8020fa78 /x11-misc/ptbatterysystemtray
parentConvert built_with_use to use deps. #261562 (diff)
downloadgentoo-2-d1644c677ba06264228706a7683400a765e7d626.tar.gz
gentoo-2-d1644c677ba06264228706a7683400a765e7d626.tar.bz2
gentoo-2-d1644c677ba06264228706a7683400a765e7d626.zip
Initial commit. Ebuild based on live ebuild in qt overlay.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/ptbatterysystemtray')
-rw-r--r--x11-misc/ptbatterysystemtray/ChangeLog10
-rw-r--r--x11-misc/ptbatterysystemtray/Manifest3
-rw-r--r--x11-misc/ptbatterysystemtray/metadata.xml5
-rw-r--r--x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild30
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/ptbatterysystemtray/ChangeLog b/x11-misc/ptbatterysystemtray/ChangeLog
new file mode 100644
index 000000000000..39276fffa8e5
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/ptbatterysystemtray
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ptbatterysystemtray/ChangeLog,v 1.1 2012/05/11 09:09:00 yngwin Exp $
+
+*ptbatterysystemtray-1.0.0_rc2 (11 May 2012)
+
+ 11 May 2012; Ben de Groot <yngwin@gentoo.org> +metadata.xml,
+ +ptbatterysystemtray-1.0.0_rc2.ebuild:
+ Initial commit. Ebuild based on live ebuild in qt overlay.
+
diff --git a/x11-misc/ptbatterysystemtray/Manifest b/x11-misc/ptbatterysystemtray/Manifest
new file mode 100644
index 000000000000..32843ffd07d6
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/Manifest
@@ -0,0 +1,3 @@
+DIST ptbatterysystemtray-1.0.0_rc2.tar.gz 234884 RMD160 9359614801642deb508fc5c0965f13ab58bb106e SHA1 70c6dbd21cb0a682a14aaf04f4356f106b9978ae SHA256 c28e43e9157df74c7e4599485c24fe8dc79201133c56d7d72f3e4eda5def12f4
+EBUILD ptbatterysystemtray-1.0.0_rc2.ebuild 596 RMD160 c0d11d8e0d20a7a66d34dc4d858ecad6018e606e SHA1 47e0c5c1fad1921d53851cc87d7dc774071a3242 SHA256 6ece40a80a239592019097fef5cef99e1fdd6f7e4cd5b69b7f5046f115cea7e3
+MISC metadata.xml 155 RMD160 654eebe07944b4d18c58e4a54c50758eceead53e SHA1 967490b59f5185a6849cb5583390dd0d0b0dd512 SHA256 94ed5876ef16dbc191744ff6b8939a0f428fcb8add316d898880e1c4c880b9e7
diff --git a/x11-misc/ptbatterysystemtray/metadata.xml b/x11-misc/ptbatterysystemtray/metadata.xml
new file mode 100644
index 000000000000..dc439f7e84f5
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
diff --git a/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
new file mode 100644
index 000000000000..e6bb2c0b3cac
--- /dev/null
+++ b/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ptbatterysystemtray/ptbatterysystemtray-1.0.0_rc2.ebuild,v 1.1 2012/05/11 09:09:00 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A simple battery monitor in the system tray"
+HOMEPAGE="https://gitorious.org/ptbatterysystemtray"
+SRC_URI="https://gitorious.org/${PN}/${PN}/archive-tarball/${PV/_/-} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_unpack() {
+ default
+ mv ${PN}-${PN} "${S}" || die
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro INSTALL_PREFIX=/usr
+}