summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-07-15 08:15:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-07-15 08:15:47 +0000
commit1724e65afba9b40b89ffeb09c9c95b87b1b57bd5 (patch)
treea512dad4bef62ec3409086d7c308c6fc0f527e3e /x11-misc/rednotebook
parentppc64 stable wrt 363185. Drop old (diff)
downloadgentoo-2-1724e65afba9b40b89ffeb09c9c95b87b1b57bd5.tar.gz
gentoo-2-1724e65afba9b40b89ffeb09c9c95b87b1b57bd5.tar.bz2
gentoo-2-1724e65afba9b40b89ffeb09c9c95b87b1b57bd5.zip
Version bump
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog7
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index b6acf95701ae..5bcf039e669c 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.47 2011/05/17 21:24:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.48 2011/07/15 08:15:46 hwoarang Exp $
+
+*rednotebook-1.1.7 (15 Jul 2011)
+
+ 15 Jul 2011; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.1.7.ebuild:
+ Version bump
17 May 2011; Markos Chandras <hwoarang@gentoo.org> -rednotebook-1.1.2.ebuild,
-rednotebook-1.1.4.ebuild:
diff --git a/x11-misc/rednotebook/rednotebook-1.1.7.ebuild b/x11-misc/rednotebook/rednotebook-1.1.7.ebuild
new file mode 100644
index 000000000000..637d569dffcf
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.7.ebuild,v 1.1 2011/07/15 08:15:47 hwoarang Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${PN}-1.1.4-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-1.1.0-disable-spell.patch"
+ distutils_src_prepare
+}