summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-04-09 07:55:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-04-09 07:55:38 +0000
commit1ee35b6d427071c510b6f8495bdcec41ca1da70d (patch)
tree5595624ffafd5472f5d943424e5610379ebaaa61 /x11-misc/synergy-plus
parentRemove last occurence of -Werror wrt #362671 by Diego Elio Pettenò <flameeye... (diff)
downloadgentoo-2-1ee35b6d427071c510b6f8495bdcec41ca1da70d.tar.gz
gentoo-2-1ee35b6d427071c510b6f8495bdcec41ca1da70d.tar.bz2
gentoo-2-1ee35b6d427071c510b6f8495bdcec41ca1da70d.zip
Remove -Werror wrt #362675 by Diego Elio Pettenò <flameeyes@gentoo.org>. Remove unnecessary die messages and empty elog.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/synergy-plus')
-rw-r--r--x11-misc/synergy-plus/ChangeLog9
-rw-r--r--x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild25
2 files changed, 24 insertions, 10 deletions
diff --git a/x11-misc/synergy-plus/ChangeLog b/x11-misc/synergy-plus/ChangeLog
index 6d5ea28e9878..3070d3abef52 100644
--- a/x11-misc/synergy-plus/ChangeLog
+++ b/x11-misc/synergy-plus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/synergy-plus
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy-plus/ChangeLog,v 1.5 2010/09/15 23:47:36 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy-plus/ChangeLog,v 1.6 2011/04/09 07:55:38 xarthisius Exp $
+
+ 09 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ synergy-plus-1.3.4.ebuild:
+ Remove -Werror wrt #362675 by Diego Elio Pettenò <flameeyes@gentoo.org>.
+ Remove unnecessary die messages and empty elog.
15 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Drop maintainership.
diff --git a/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild b/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild
index e9c49b0d1c5c..e677c1b28e02 100644
--- a/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild
+++ b/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild
@@ -1,13 +1,16 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild,v 1.5 2010/07/22 11:32:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy-plus/synergy-plus-1.3.4.ebuild,v 1.6 2011/04/09 07:55:38 xarthisius Exp $
EAPI="2"
+inherit autotools
+
DESCRIPTION="Lets you easily share a single mouse and keyboard between multiple computers"
+HOMEPAGE="http://code.google.com/p/synergy-plus/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
#SRC_URI="mirror://google/files/${PN}/${P}.tar.gz"
-HOMEPAGE="http://code.google.com/p/synergy-plus/"
+
LICENSE="GPL-2"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
SLOT="0"
@@ -26,16 +29,22 @@ DEPEND="${CDEPEND}
x11-proto/xineramaproto
x11-libs/libXt"
+src_prepare() {
+ sed -i -e '/ACX_CXX_WARNINGS_ARE_ERRORS/d' configure.in || die #362675
+
+ eautoreconf
+}
+
src_install () {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
insinto /etc
- doins examples/synergy.conf || die "doins failed"
+ doins examples/synergy.conf || die
}
pkg_postinst() {
- elog
+ echo ''
elog "${PN} can also be used to connect to computers running Windows or Mac OS X."
elog "Visit ${HOMEPAGE} to find the Windows client and Mac OS X client."
- elog
+ echo ''
}