summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-24 13:45:54 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-24 13:45:54 +0000
commitcc2ae04bf141f7464538fb5eebe783e38a791da0 (patch)
treea9ae38e32cc4371c04a4f8a8e4153fe783c14fb2 /x11-misc/treeline
parentFixes for FreeBSD: use type -P true instead of hardcoded path and force verbo... (diff)
downloadgentoo-2-cc2ae04bf141f7464538fb5eebe783e38a791da0.tar.gz
gentoo-2-cc2ae04bf141f7464538fb5eebe783e38a791da0.tar.bz2
gentoo-2-cc2ae04bf141f7464538fb5eebe783e38a791da0.zip
Remove all overshadowed ebuilds. Pick only aspell dict as ispell is going out.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/ChangeLog7
-rw-r--r--x11-misc/treeline/files/treeline-1.2.3-nocompile.patch12
-rw-r--r--x11-misc/treeline/treeline-1.2.3.ebuild73
-rw-r--r--x11-misc/treeline/treeline-1.2.4.ebuild73
-rw-r--r--x11-misc/treeline/treeline-1.4.0.ebuild4
5 files changed, 8 insertions, 161 deletions
diff --git a/x11-misc/treeline/ChangeLog b/x11-misc/treeline/ChangeLog
index c8ec0bc59e8d..7fa728377e62 100644
--- a/x11-misc/treeline/ChangeLog
+++ b/x11-misc/treeline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/treeline
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.48 2012/01/04 21:02:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.49 2012/04/24 13:45:53 scarabeus Exp $
+
+ 24 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/treeline-1.2.3-nocompile.patch, -treeline-1.2.3.ebuild,
+ -treeline-1.2.4.ebuild, treeline-1.4.0.ebuild:
+ Remove all overshadowed ebuilds. Pick only aspell dict as ispell is going out.
04 Jan 2012; Brent Baude <ranger@gentoo.org> treeline-1.4.0.ebuild:
Marking treeline-1.4.0 ppc for bug 391511
diff --git a/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch b/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch
deleted file mode 100644
index 297a926d9091..000000000000
--- a/x11-misc/treeline/files/treeline-1.2.3-nocompile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- install.py.orig 2009-06-06 19:21:00.000000000 +0200
-+++ install.py 2009-06-06 19:26:28.000000000 +0200
-@@ -230,7 +230,8 @@
- pythonBuildDir = os.path.join(buildRoot, pythonPrefixDir[1:])
-
- if os.path.isdir('source'):
-- compileall.compile_dir('source', ddir=os.path.join(prefixDir, 'source'))
-+ # don't compile, let our eclass handle that
-+ # compileall.compile_dir('source', ddir=os.path.join(prefixDir, 'source'))
- print 'Installing files...'
- print ' Copying python files to %s' % pythonBuildDir
- removeDir(pythonBuildDir) # remove old?
diff --git a/x11-misc/treeline/treeline-1.2.3.ebuild b/x11-misc/treeline/treeline-1.2.3.ebuild
deleted file mode 100644
index 809cff70ede9..000000000000
--- a/x11-misc/treeline/treeline-1.2.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.2.3.ebuild,v 1.7 2010/07/14 16:33:48 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="xml"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python
-
-DESCRIPTION="TreeLine is a structured information storage program."
-HOMEPAGE="http://treeline.bellz.org/"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="spell"
-
-LANGS="de fr"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
- SRC_URI="${SRC_URI} linguas_${lang}? ( mirror://berlios/${PN}/${PN}-i18n-${PV}a.tar.gz )"
-done
-
-DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
- dev-python/PyQt4[X]"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/TreeLine"
-
-src_unpack() {
- unpack ${P}.tar.gz
- for lang in ${LANGS}; do
- if use linguas_${lang}; then
- tar xozf "${DISTDIR}"/${PN}-i18n-${PV}a.tar.gz \
- TreeLine/doc/{readme_${lang}.trl,README_${lang}.html} \
- TreeLine/translations/{treeline_${lang}.{qm,ts},qt_${lang}.{qm,ts}} || die
- fi
- done
-}
-
-src_prepare() {
- # Let's leave compiling to python_mod_optimize().
- epatch "${FILESDIR}"/${P}-nocompile.patch
-
- rm doc/LICENSE
-
- python_copy_sources
-
- preparation() {
- # install into proper python site-packages dir
- sed -i "s;prefixDir, 'lib;'$(python_get_sitedir);" install.py
- }
- python_execute_function -s preparation
-}
-
-src_install() {
- installation() {
- "$(PYTHON)" install.py -x -p /usr/ -d /usr/share/doc/${PF} -b "${D}"
- }
- python_execute_function -s installation
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/x11-misc/treeline/treeline-1.2.4.ebuild b/x11-misc/treeline/treeline-1.2.4.ebuild
deleted file mode 100644
index f8e4db8e9bb3..000000000000
--- a/x11-misc/treeline/treeline-1.2.4.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.2.4.ebuild,v 1.2 2010/07/14 16:33:48 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="xml"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python
-
-DESCRIPTION="TreeLine is a structured information storage program."
-HOMEPAGE="http://treeline.bellz.org/"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="spell"
-
-LANGS="de fr"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
- SRC_URI="${SRC_URI} linguas_${lang}? ( mirror://berlios/${PN}/${PN}-i18n-${PV}a.tar.gz )"
-done
-
-DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
- dev-python/PyQt4[X]"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/TreeLine"
-
-src_unpack() {
- unpack ${P}.tar.gz
- for lang in ${LANGS}; do
- if use linguas_${lang}; then
- tar xozf "${DISTDIR}"/${PN}-i18n-${PV}a.tar.gz \
- TreeLine/doc/{readme_${lang}.trl,README_${lang}.html} \
- TreeLine/translations/{treeline_${lang}.{qm,ts},qt_${lang}.{qm,ts}} || die
- fi
- done
-}
-
-src_prepare() {
- # Let's leave compiling to python_mod_optimize().
- epatch "${FILESDIR}"/${PN}-1.2.3-nocompile.patch
-
- rm doc/LICENSE
-
- python_copy_sources
-
- preparation() {
- # install into proper python site-packages dir
- sed -i "s;prefixDir, 'lib;'$(python_get_sitedir);" install.py
- }
- python_execute_function -s preparation
-}
-
-src_install() {
- installation() {
- "$(PYTHON)" install.py -x -p /usr/ -d /usr/share/doc/${PF} -b "${D}"
- }
- python_execute_function -s installation
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/x11-misc/treeline/treeline-1.4.0.ebuild b/x11-misc/treeline/treeline-1.4.0.ebuild
index 9e674057921c..bc5b5cf777e2 100644
--- a/x11-misc/treeline/treeline-1.4.0.ebuild
+++ b/x11-misc/treeline/treeline-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.4.0.ebuild,v 1.4 2012/01/04 21:02:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.4.0.ebuild,v 1.5 2012/04/24 13:45:53 scarabeus Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -24,7 +24,7 @@ for lang in ${LANGS}; do
SRC_URI="${SRC_URI} linguas_${lang}? ( mirror://berlios/${PN}/${PN}-i18n-${PV}a.tar.gz )"
done
-DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
+DEPEND="spell? ( app-text/aspell )
dev-python/PyQt4[X]"
RDEPEND="${DEPEND}"
RESTRICT_PYTHON_ABIS="3.*"