summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-02-13 00:58:48 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-02-13 00:58:48 +0000
commita38d054813641bf832aff699a47734ca32fd857c (patch)
treef96ef6873c60ca550c3543a9a09b74b4a9c27bd2 /x11-misc/xac
parentStable on amd64, bug 162460. (diff)
downloadgentoo-2-a38d054813641bf832aff699a47734ca32fd857c.tar.gz
gentoo-2-a38d054813641bf832aff699a47734ca32fd857c.tar.bz2
gentoo-2-a38d054813641bf832aff699a47734ca32fd857c.zip
Fixed missing gzopen issue.
(Portage version: 2.1.2-r8)
Diffstat (limited to 'x11-misc/xac')
-rw-r--r--x11-misc/xac/ChangeLog6
-rw-r--r--x11-misc/xac/files/xac-lz.patch11
-rw-r--r--x11-misc/xac/xac-0.6_pre1.ebuild15
3 files changed, 27 insertions, 5 deletions
diff --git a/x11-misc/xac/ChangeLog b/x11-misc/xac/ChangeLog
index 2d553a81b648..3bb636d6032e 100644
--- a/x11-misc/xac/ChangeLog
+++ b/x11-misc/xac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xac
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.4 2007/02/11 07:24:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/ChangeLog,v 1.5 2007/02/13 00:58:48 josejx Exp $
+
+ 13 Feb 2007; Joseph Jezak <josejx@gentoo.org> +files/xac-lz.patch,
+ xac-0.6_pre1.ebuild:
+ Fixed missing gzopen issue.
11 Feb 2007; Joseph Jezak <josejx@gentoo.org> -xac-0.5.ebuild,
xac-0.6_pre1.ebuild:
diff --git a/x11-misc/xac/files/xac-lz.patch b/x11-misc/xac/files/xac-lz.patch
new file mode 100644
index 000000000000..98d84104adb8
--- /dev/null
+++ b/x11-misc/xac/files/xac-lz.patch
@@ -0,0 +1,11 @@
+--- src/setup.bak 2007-02-12 19:52:58.000000000 -0500
++++ src/setup.py 2007-02-12 19:51:44.000000000 -0500
+@@ -2,7 +2,7 @@
+ from distutils.core import setup, Extension
+
+ pci_module = Extension("pci",
+- libraries = ["pci"],
++ libraries = ["pci", "z"],
+ sources = ["pcimodule.c"])
+
+ vbe_module = Extension("vbe",
diff --git a/x11-misc/xac/xac-0.6_pre1.ebuild b/x11-misc/xac/xac-0.6_pre1.ebuild
index 9d623dee4568..665e5c52e6c3 100644
--- a/x11-misc/xac/xac-0.6_pre1.ebuild
+++ b/x11-misc/xac/xac-0.6_pre1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre1.ebuild,v 1.2 2007/02/11 07:24:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre1.ebuild,v 1.3 2007/02/13 00:58:48 josejx Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
@@ -16,11 +16,18 @@ RDEPEND=">=dev-lang/python-2.3
|| ( x11-base/xorg-server virtual/x11 )"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ ### Patch for -lz
+ epatch ${FILESDIR}/${PN}-lz.patch
+
### Replace /usr/lib/xac with libdir version
- cd "${S}"
sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
+}
+src_compile() {
### Compile the C bindings
cd "${S}"/src
### I'm not sure of a better way to do this yet