summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-14 11:36:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-14 11:36:53 +0000
commitb5403f228a39ac931f4148dada48fb0498f21591 (patch)
treec6ae4bbb15a3acbbd40b89297d42fce18ba5cef0 /x11-misc/xcalib/xcalib-0.8.ebuild
parentCall epatch only once. This should be default behavior in media- ebuilds. (diff)
downloadgentoo-2-b5403f228a39ac931f4148dada48fb0498f21591.tar.gz
gentoo-2-b5403f228a39ac931f4148dada48fb0498f21591.tar.bz2
gentoo-2-b5403f228a39ac931f4148dada48fb0498f21591.zip
Add a patch to respect LDFLAGS; fix broken dependencies; use the correct path for X11 (no more /usr/X11R6).
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-misc/xcalib/xcalib-0.8.ebuild')
-rw-r--r--x11-misc/xcalib/xcalib-0.8.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/x11-misc/xcalib/xcalib-0.8.ebuild b/x11-misc/xcalib/xcalib-0.8.ebuild
index cc4e1fe79ae0..4c55af7fd31d 100644
--- a/x11-misc/xcalib/xcalib-0.8.ebuild
+++ b/x11-misc/xcalib/xcalib-0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcalib/xcalib-0.8.ebuild,v 1.3 2008/04/12 12:03:08 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcalib/xcalib-0.8.ebuild,v 1.4 2008/04/14 11:36:52 flameeyes Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs multilib
DESCRIPTION="xcalib is a tiny monitor calibration loader for X.org"
HOMEPAGE="http://www.etg.e-technik.uni-erlangen.de/web/doe/xcalib/"
@@ -13,18 +13,27 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="
- x11-libs/libX11
+RDEPEND="x11-libs/libX11
x11-libs/libXext
- x11-libs/libXxf86vm
- x11-proto/xf86vidmodeproto
-"
-RDEPEND=""
+ x11-libs/libXxf86vm"
+
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ XINCLUDEDIR=/usr/include \
+ XLIBDIR=/usr/$(get_libdir) \
|| die 'make failed'
}